RTX 3080 + AMD integrated GPU: second monitor connected but black


I use debian 11 testing with non-free firmware. I installed nvidia-drivers.
I have two GPU cards.

$ lspci | grep -E "VGA|3D"
01:00.0 VGA compatible controller: NVIDIA Corporation GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB] (rev a1)
06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne (rev c4)


$ xrandr --listproviders                 Wed 12 May 2021 06:45:07 PM CEST
Providers: number : 2
Provider 0: id: 0x54 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 1 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:06:00.0
Provider 1: id: 0x1fa cap: 0x2, Sink Output crtcs: 4 outputs: 4 associated providers: 0 name:NVIDIA-G0

I have two monitors: internal and an external AOC U2790B connected via Nvidia card HDMI port.
From nvidia-setting, I can see the external monitor is connected. Also in Xorg.0.log

[  3615.929] (--) NVIDIA(GPU-0):
[  3615.960] (--) NVIDIA(GPU-0): AOC U2790B (DFP-2): connected
[  3615.960] (--) NVIDIA(GPU-0): AOC U2790B (DFP-2): Internal TMDS
[  3615.960] (--) NVIDIA(GPU-0): AOC U2790B (DFP-2): 600.0 MHz maximum pixel clock
[  3615.960] (--) NVIDIA(GPU-0):

However, the monitor is black.

Here is the bug report:
nvidia-bug-report.log.gz (157.3 KB)

Thank you very much for looking at this.

The nvidia gpu is in offload mode and the output sink feature in conjunction with an amd gpu as primary is wip, doesn’t work currently. Please switch to nvidia as primarygpu:
Very outdated: https://wiki.debian.org/NVIDIA%20Optimus#Using_NVIDIA_GPU_as_the_primary_GPU

1 Like

Thank you very much for your reply.

Indeed, it is outdated and it was for intel integrated GPU. I don’t have /etc/X11/xorg.conf .

Is there any new documentation?

I used the link you posted. It solves my problem. Thx.

As you noticed in the other thread, there’s an easier way to configure this now but the old info from the debian wiki still works. Maybe ping the wiki maintainers to update the info as it’s more complicated that it should be.