RTX A6000 Only Sending 6-bit Color Depth to Adder KVM Tx Unit

We purchased 2 pre-configured BOXX workstations, each with the Asus Pro WS WRX80E-SAGE SE WIFI mother board, and the first with 2x NVIDIA RTX A6000, and the second with 2x NVIDIA RTX A5000. We are running CentOS 8.3 with DaVinci Resolve 18.

We are rack mounting the BOXX workstations and going to be utilizing the Adder Infinity 2122 ethernet KVM units for the BOXX workstations to be accessed from any desired bay. The Adder KVMs are tested and working with other MacStudio workstations onsite.

The Adder requires a minimum of 8-bit color depth to function. CentoS 8.3 says it’s kicking out 24-bit color depth, the nvidia-settings says it is kicking out 24-bit color depth, if I hook up a local display directly to the NVIDIA GPU I get full 24-bit color depth. But when the Adder transmitter is plugged into the NVIDIA A6000 it only ever receives a 6-bit color depth, and video transmission fails.

In speaking with the DisplayPort expert at Adder, he thinks this is a CentOS/NVIDIA issue: “If the PC says it’s doing 24bpp/8bpc, then at the upper layer it likely is. However, at the low-level DP layer it’s possible the GPU/driver failed to link train high enough (or due to some other issue) only then got a link good enough to fit the resolution down it but at 6bpc. So, the GPU would be converting on-the-fly from the 24bpp/8bpc from the OS into 6bpc.”

I have tried drivers from 470 through 525 with varying degrees of compatibility but none have allowed for video to get from the NVIDIA to the Adder correctly. Also tried adjusting the Color Range between Limited and Full, and Dithering depth between 6 and 8 bpmAnd worked with the xorg.conf file to try and force 24 bit, even though CentOS already thinks it is kicking out 24-bit…

nvidia-bug-report.log.gz (1.3 MB)

Please check if this is the same bug as this:
Though I guess you already tried downgrading to driver v515?

I had seen that post before creating my own post. I’m currently running 515.86.01. I’ve tested with 525.85 and 525.78 before eventually ending up on 515.86. I’ve seen the same issue across all versions of the NVIDIA driver.