RTX engine creation failed

Create doesn’t seem to be able to start the RTX engine, it’s running fine if I open the Kit app as well as Audio2Face.

I was eager to try Create but right now I can’t seem to get it running.

I tried uninstalling the drivers and doing a clean install of the latest studio drivers with no luck.

I attached all the relevant information I could find I hope you can help me fix this issue.

system info.tif (65.9 KB)
viewport bug.tif (196.4 KB)

logs.zip (951.7 KB)

Audio2Face.tif (528.9 KB)
nvidia-smi.tif (137.7 KB)
Studio Drivers.tif (1.4 MB)

Any way to work around this issue?

hello @TerryPXM -
I am sorry you are having issues with Create. Thanks for the logs. I want to try one test at the moment. Want to start Create with a single GPU (going to use your 3090).

Note: the picture above as a final path of create-2021.1.1 , yours will be different based on the version of create you have installed.

1 Like

Hello @TerryPXM! The development team is working on a solution to this issue and has asked me to get a bit more information from you. Could you please let me know your Operating System, GPU(s), and the GPU Driver you are using?

Operating System: ?
GPU(s): ?
GPU Driver: ?

Any update on this? I’m having the same problem as other users. RTX A5000, intel i7 in a laptop with the latest driver (clean install). Windows 10. I have tried all the remediation steps noted above to no avail.

Hello @spobiner! I need a few more details from so that we can help troubleshoot the issue. Could you attached your logs found here: C:\Users\<USERNAME>\.nvidia-omniverse\logs\Kit\Create

Do you use more than one GPU?

Hi @WendyGram! I have only the one GPU (RTX A5000 Laptop GPU). The folder you directed me to does not exist but I see <…>\Create.Next and am attaching logs from there.

2022.1.zip (893.2 KB)

PS - I checked with a colleague who has the same configuration and he hasn’t seen any of these errors.

same problem here
it’s a Laptop with Windows 10, GPU P600, Driver 527.27

I tried also the singlegpu solution with the same result. In the batch output it complains

[Error] [rtx.neuraylib.plugin] Failed to load neuray plugin 'libiray'.
after searching for
even so that

does exist (Windows doesn’t like forward slashes in cmd it would work in PowerShell)
Not sure if that is another issue


Thanks everyone,
Here are some information based on the logs you have attached:

Your log shows that you may have changed the default cache folder during installation to somewhere else to be in Program Files, and therefore cache files cannot be saved there.
I recommend reverting the location of the caches back to the default “User” folder or another location that the app has write access to.

P600 is a Pascal GPU and it is not supported.
Omniverse RTX renderer requires RTX GPUs as a minimum requirement.

The log shows you are running an unsupported 472.47 driver, please try to upgrade to a newer driver (e.g. 527.37). You are also hitting another rare multi-GPU issue that is under investigation, which we are currently not able to reproduce.
A solution is to run the app in single-GPU mode by running omni.create.singlegpu.bat after upgrading your driver.

thanks it makes sense high resolution rendering is not available but not supported as in not even wireframe rendering, use a third party tool to create and visualise usd’s ?

You should be able to run Create with Pixar’s Storm renderer using this batch: omni.create.hdstorm.bat.
Note that due to its limitations and low VRAM, it might not be the most stable renderer at the moment and should work for small USD scenes.

In the current version of Create, Iray is not supported on non-RTX GPUs, but it is in the road map to get such renderers working again in the near future on non-rtx GPUs.

ok thanks, should be fine for now