RTX engine creation failed

Any idea what is wrong? I have 2 3090s in my system. They are from different hardware vendors if that matters? I can get it to launch with this from command line.

omni.create.singlegpu.bat --/renderer/activeGpu=0

I’m having the same issue, I just added an Aorus rtx 3080 EGPU to my system and omniverse is giving me the same error, it will work without the EGPU but, whats the point?
I want it to work on my 3080

You can probably launch it with the following on only the egpu

omni.create.singlegpu.bat --/renderer/activeGpu=1

I think the error stems from trying to use multiple GPUs

im sorry im a nooob… what exactly do I do with that line of code and where does it input? how do I use that thing u sent

You’ll need to enter this in the command line in windows.

Hello @rubberjohnny & @flyinglotus1983! Sorry to hear you are having trouble. I’ve seen this issue come up once before. (Here is the forum post: RTX engine creation failed) Our Tech support suggested testing a single GPU on startup.

I have messaged him for more help, but let me know if you are able to launch the RTX Engine with the suggestion from the earlier post!

hello @flyinglotus1983 -
The link that WendyGram posted above should show you how to start just the EGPU. If issues or unclear, please tell me.

In addition can i request some log files?
Below is an example location of the folder “Kit” that i would like to request. The user name under C:\Users\xxxx needs to be replaced with your username. Then zip up the contents of the Kit folder and post back.

Kit.zip (1.0 MB)

Here are is the kit folder. I can launch with one GPU using the command line. Launching normally with both GPU results in the RTX engine error and viewport is black.

hello @rubberjohnny -
Thanks for the files. Looks like an issue with the shadercache. Can you please try the latest version of Create (2022.1.0) This is now available on the Launcher.

Hi I have Create 2022.1.0-rc 22 installed. I just tried and get the same error. Here is the latest .kit archive. thanks
Kit.zip (1.1 MB)

Hi everyone! The development team is working on a solution to this issue and has asked me to get a bit more information from you all. Could you please let me know your Operating System, GPU(s), and the GPU Driver you are using?

Operating System: ?
GPU(s): ?
GPU Driver: ?

Operating System:

Windows 10 Home, 10.0.19044 Build 19044

GPUs: I have two…

NVIDIA GeForce RTX 3090 Founders Edition (Video Bus: PCIe v4.0 x16 (16.0 GT/s) @ x8 (16.0 GT/s)

MSI RTX 3090 AERO/VENTUS 3X OC 24G (Video Bus: PCIe v4.0 x16 (16.0 GT/s) @ x8 (2.5 GT/s)

GPU Driver: 472.47