run an .exe file on different computers/GPUs problems with .exe-file of CUDA program


I’ve developed a CUDA program with Visual Studio C++ Express Edition and created an .exe file. The exe runs fine on the developement computer but it doesn’t work correct on others!
It’s the same problem with .exe files of the CUDA SDK samples. They work fine on the “source” computer but the screen stops or flickers on others. I.e. the program runs (without error messages), it reacts on mouse and key commands, but the display and, I guess, the computations on GPU doesn’t work. For example the CUDA particles sample: The scene is displayed but the particles doesn’t move. Output of the particle positions shows that they really don’t change!

I’ve created the .exe files on an Laptop with GeForce 8600 M GS and tried to run it on a desktop computer with a GeForce 8800 GTX (both Windows XP).

What’s wrong with the .exe? Is it normal that it doesn’t work on computers with different GPUs? Or is it due to the VS Express Edition?


Maybe it has something to do with the cuda libs?
update the driver on your desktop. Older drivers didn’t have cuda inside them. But the cuda lib was installed using the toolkit.

or the other way around.

What version are you using?

Are you compiling your code with “-arch=sm_11” by any chance?

The 8800 GTX is compute 1.0 and will not run compute 1.1 code.

Thank you both for your answers!

I’ve finally noticed that only the .exe file of the CUDA Particles sample doesn’t run on another Computer. Every other sample I’ve tested till now works fine…
The program I’ve developed is based on CUDA Particles and hence I guess it doesn’t work as .exe, too…

I’ve installed the same drivers and toolkit on both computers (Version 1.1).
And I compile the CUDA Particles sample with “-arch=sm_10”.

Why does any other sample work? What’s wrong with CUDA Particles? Is there any project setting different from the others?

It works now! :biggrin:

I’ve added “-I…/…/common/GLEW/include” as nvcc command (it’s in all other samples already included) and now .exe files of the CUDA Particles sample and of my own program run on other computers, too.
Obviously the GLEW libs had missed…