run deepstream_test1_app stuck in g_main_loop_run (loop);

hi
i have a trouble in running deepstream_test1_app
after i run ./deepstream-test1-app …/…/…/samples/streams/sample_720p.h264
program stuck in g_main_loop_run (loop);

test@lb-ubnt:~/qin/DeepStream_Release/sources/apps/deepstream-test1$ make
cc -I…/…/includes pkg-config --cflags gstreamer-1.0 -c -o deepstream_test1_app.o deepstream_test1_app.c
cc -o deepstream-test1-app deepstream_test1_app.o pkg-config --libs gstreamer-1.0

test@lb-ubnt:~/qin/DeepStream_Release/sources/apps/deepstream-test1$ ls
deepstream-test1-app deepstream_test1_app.c deepstream_test1_app.o dstest1_pgie_config.txt Makefile README

test@lb-ubnt:~/qin/DeepStream_Release/sources/apps/deepstream-test1$ ./deepstream-test1-app …/…/…/samples/streams/sample_720p.h264
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused

(gst-plugin-scanner:27506): Clutter-CRITICAL **: Unable to initialize Clutter: Could not initialize Gdk

(gst-plugin-scanner:27506): Clutter-Gst-CRITICAL **: Unable to initialize Clutter
Now playing: …/…/…/samples/streams/sample_720p.h264
Running…

hi
i havr solved this program Because I don’t have a monitor.

https://devtalk.nvidia.com/default/topic/1042392/deepstream-for-tesla/not-able-to-run-sample-code/
How to resolve following under link

https://devtalk.nvidia.com/default/topic/1037691/deepstream-for-tesla/encoding-and-saving-to-a-file-with-deepstream_test1_app-c/

glad to hear that, thanks for replying.