Run xgboost with GPU error.

I install xgboost and want to use its GPU acceleration with nano. But I got error:

terminate called after throwing an instance of ‘thrust::system::system_error’
what(): parallel_for failed: no kernel image is available for execution on the device
Aborted (core dumped)

Anyone can help me to fixted ? Thanks

Hi,

This is a known issue and we are already working on it.
Will update more information with you later.

Thanks.

Replacing Thrust that is in the /usr/local/cuda/include folder with the open source Thrust is a workaround that I have found that fixes this error. There may be scripts in there that are incompatible with the Jetson because it was not specifically formulated for ARM CUDA, but it worked for me.

The problem is solved here: https://github.com/dmlc/xgboost/issues/4355

Hi,

Thanks for your feedback.
Good to know it works now.

There is a mistake in the Thrust of JetPack 4.2.
We will fix this issue in our next release which should be CUDA-10.1.

When my train data has 1 million rows and 3 columns, my Nano shut down and power off immediately.

Hi,

What kind of power supply do you use?
Nano will shut down directly when starving for power.

Here is some discussion for the power supply for your reference:
https://devtalk.nvidia.com/default/topic/1048640/jetson-nano/power-supply-considerations-for-jetson-nano-developer-kit/

Thanks.

I use a power adapter for mobile with 5V-2A through Micro-B usb. So from your links, should I use a 5V-4A power supply ?

Hi,

YES.

This discussion can give you some information about the power supply:
https://devtalk.nvidia.com/default/topic/1048640/jetson-nano/power-supply-considerations-for-jetson-nano-developer-kit/

You can set your device into 10W mode to see if works first:

sudo nvpmodel -m 1

Thanks.