Running and testing Yolo-v2 on Jetson Tx2 with Darknet

Hello everyone,
I’m new to AI world.I’m working on Jetson TX2 and trying to test yolov2 on the Jetson TX2 using Darknet. I did the following steps:

1-I downloaded Darknet from Github

https://github.com/pjreddie/darknet.git

2-I modified the MakeFile so that it complies with the Jetson

GPU=1
CUDNN=1
OPENCV=1
OPENMP=0
DEBUG=0

ARCH= -gencode arch=compute_53,code=[sm_53,compute_53]
-gencode arch=compute_62,code=[sm_62,compute_62]

3- I ran the command $ make

4- darknet was then built successfully

5- I downloaded the weights Files and cfg files

example: yolovs.cfg and yolov2.weights

the weights file was saved in the base directory
the cfg file is saved in the cfg/subdirectory

6- I ran the follwing command to test yolo on an Image:

./darknet yolo test cfg/yolov2.cfg yolov2.weights data/dog.jpg

It returns after computing with the following Error:

31 detection
mask_scale: Using default ‘1.000000’
Loading weights from yolov2.weights…Done!
data/dog.jpg: Predicted in 0.012205 seconds.
Gtk-Message: 15:14:42.358: Failed to load module “canberra-gtk-module”

Anyone has an idea what is the reason behind it?

Thanks in advance

Hi,

Do you mean this one?

Gtk-Message: 15:14:42.358: Failed to load module "canberra-gtk-module"

This is a harmless warning.
It looks like YOLO run well on your environment.

data/dog.jpg: Predicted in 0.012205 seconds.

Thanks.

Hi thanks for your info. It actually try to predict somthing in the dog imgage, but in the end it displays the image with out bounding boxes or classification. Do you know what could the problem be ?

thanks in advance

Hi,

Sorry for the late.

A common issue is the different image pre-processing steps.
Here is a sharing for running darknet on Jetson Nano:
https://pysource.com/2019/08/29/yolo-v3-install-and-run-yolo-on-nvidia-jetson-nano-with-gpu/

Although it is for YOLOv3, the overall steps should be similar.
Could you check it to see if any difference in the setting first?

Thanks.