Running CaffeMNIST reference app on DS 3.0/ Xavier

Hello,

I am using CaffeMNIST reference app for my use case. As instructed in Readme file there are certain pre-requisites as follows to run the app:
Pre-requisites:

Copy mnist_mean.binaryproto and mnist.caffemodel from the data/mnist directory in the TensorRT SDK to the CaffeMNIST/data directory

I have flashed Xavier with Jetpack 4.1 and hence TensorRT is inbuilt in that so there is no TensorRT SDK separately and hence both files are missing. Could you please lemme know how it will affect the implementation of the app?

After that the following command was modified since TensorRT SDK root folder is not there as mentioned above:

cmake -D DS_SDK_ROOT=<DS SDK Root> -D TRT_SDK_ROOT=<TRT SDK Root> -D CMAKE_BUILD_TYPE=Release ..

to

cmake -D DS_SDK_ROOT=<DS SDK Root> -D CMAKE_BUILD_TYPE=Release ..

after that when I run

make

following error comes up:

nvidia@jetson-0423018054743:~/Downloads/deepstream_reference_apps-master/CaffeMNIST/nvdsinfer_custom_impl_CaffeMNIST/build$ make
[ 33%] Building CXX object CMakeFiles/nvdsinfer_custom_impl_CaffeMNIST.dir/nvdsiplugin_CaffeMNIST.cpp.o
In file included from /home/nvidia/Downloads/deepstream_reference_apps-master/CaffeMNIST/nvdsinfer_custom_impl_CaffeMNIST/nvdsiplugin_CaffeMNIST.cpp:26:0:
/home/nvidia/Downloads/deepstream_reference_apps-master/CaffeMNIST/nvdsinfer_custom_impl_CaffeMNIST/factoryCaffeMNISTLegacy.h:39:10: fatal error: fp16.h: No such file or directory
 #include "fp16.h"
          ^~~~~~~~
compilation terminated.
CMakeFiles/nvdsinfer_custom_impl_CaffeMNIST.dir/build.make:62: recipe for target 'CMakeFiles/nvdsinfer_custom_impl_CaffeMNIST.dir/nvdsiplugin_CaffeMNIST.cpp.o' failed
make[2]: *** [CMakeFiles/nvdsinfer_custom_impl_CaffeMNIST.dir/nvdsiplugin_CaffeMNIST.cpp.o] Error 1
CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/nvdsinfer_custom_impl_CaffeMNIST.dir/all' failed
make[1]: *** [CMakeFiles/nvdsinfer_custom_impl_CaffeMNIST.dir/all] Error 2
Makefile:83: recipe for target 'all' failed
make: *** [all] Error 2

Can someone please guide me what I am doing wrong?

Hi meena015,

We have released the DeepSteam SDK 4.0 last week, please try to move this new version for more features and supports, see https://devtalk.nvidia.com/default/topic/1057879/announcements/announcing-deepstream-sdk-4-0-/

Thanks

Hello,
I am looking to rectify the error as mentioned above. Could you please tell me how to do that using DS3.0?

Hi,
The sample is supported on desktop GPU platforms, not Jetson platforms.

Thanks DaneLLL for your reply.
How could we run it on Desktop GPU? Would it not require to go through the same steps to install TensorRT and other dependencies that is required for Deepstream to run? It is given in the reference apps of NVIDA deepstream on Github and how it cannot be supported on Jetson?

I tried running it on Desktop just to give your suggestion a try but since TensorRT and other dependencies are missing, I could not do that. What am I supposed to do now with Xavier? Please find below the error log when I tried to run it on Desktop GPU:

cmake -D DS_SDK_ROOT=/Downloads/DeepStreamSDK-Jetson-3.0_EA_beta5.0/deepstream_sdk_on_jetson -D CMAKE_BUILD_TYPE=Release ..
-- The C compiler identification is GNU 7.4.0
-- The CXX compiler identification is GNU 7.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Found CUDA: /usr/local/cuda-10.0 (found suitable exact version "10.0") 
CMake Error at CMakeLists.txt:42 (MESSAGE):
  -- Unable to find TensorRT headers.  Please set path using -DTRT_SDK_ROOT

-- Configuring incomplete, errors occurred!
See also "/Downloads/deepstream_reference_apps-master/CaffeMNIST/nvdsinfer_custom_impl_CaffeMNIST/build/CMakeFiles/CMakeOutput.log".
See also "/Downloads/deepstream_reference_apps-master/CaffeMNIST/nvdsinfer_custom_impl_CaffeMNIST/build/CMakeFiles/CMakeError.log".

Hi,
For running [DS3.0 for Tesla] package, you have to install CUDA, cuDNN, TensorRT.
We have TensorRT releases for desktop GPUs:

As of now yolo application supports both desktop GPUs and Jetson platforms.
https://github.com/NVIDIA-AI-IOT/deepstream_reference_apps/tree/master/yolo