Running code on iGPU vs dGPU

I want to use ‘CUDA_VISIBLE_DEVICES=0,1,2,3’, based on which iGPU(0,1) or dGPU(0,1), i want to run my program on. How are the GPUs numbered ?

Dear dhingratul,

You can get GPU numbers information like below via /NVIDIA_CUDA-9.2_Samples/1_Utilities/deviceQuery# ./deviceQuery

./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: “Graphics Device”
CUDA Driver Version / Runtime Version 9.2 / 9.2
CUDA Capability Major/Minor version number: 7.2
Total amount of global memory: 24762 MBytes (25964822528 bytes)
( 8) Multiprocessors, ( 64) CUDA Cores/MP: 512 CUDA Cores
GPU Max Clock rate: 1186 MHz (1.19 GHz)
Memory Clock rate: 13 Mhz
Memory Bus Width: 64-bit
L2 Cache Size: 524288 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(131072), 2D=(131072, 65536), 3D=(16384, 16384, 16384)
Maximum Layered 1D Texture Size, (num) layers 1D=(32768), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(32768, 32768), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: No
Integrated GPU sharing Host Memory: Yes
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device supports Compute Preemption: Yes
Supports Cooperative Kernel Launch: Yes
Supports MultiDevice Co-op Kernel Launch: Yes
Device PCI Domain ID / Bus ID / location ID: 0 / 0 / 0
Compute Mode:

When i run this on DRIVE, it shows me 1 CUDA capable device is detected, whereas there must be atleast two, iGPU and dGPU. When i run it on Jetson AGX, it shows me 1, with the name “Xavier”, which is iGPU, but this is missing in the DRIVE.

Dear dhingratul,

I’m not sure what platform you have, if the platform is E3550, there is no dGPU. Please see “Table 1-2. Product Features per Configuration” in below link file.

https://developer.nvidia.com/drive/earlyaccess/docs/secure/DRIVE_AGX_DevKit_Product_Brief_v2.pdf

NVIDIA DRIVE™ AGX Developer System (E3550) : There is no dGPU.
NVIDIA DRIVE™ AGX Pegasus System (P3570) : Optional. The NVIDIA DRIVE™ AGX Developer System can be configured to mimic NVIDIA DRIVE™ AGX Pegasus System or NVIDIA DRIVE™ AGX Xavier System. Please contact NVIDIA for more information.

Dear dhingratul,
As Steve said, deviceQuery list all the available GPUs on the Tegra.
It lists the GPU numbers in the decreasing order of their computation power.
If you are referring to Device 0: “Graphics Devie” entry in the deviceQuery output, It is just a name that is given. Just to avoid confusion, please check iGPU has CUDA capability 7.2 and dGPU has CUDA capability 7.0 in deviceQuery output.

I indeed have E3550, but even in that case ./deviceQuery should show two iGPUs, I just see one.

Dear dhingratul,
When you run deviceQuery on Tegra A, it shows just the GPUs on TegraA system. You need to login to Tegra B to know other iGPU details.

Thanks, but I can still run my code on Tegra A or Tegra B logged in through either? If so, how?

Dear dhingratul,
The two Tegra SoC are packed into one system. You can ssh from one Tegra to other. Also, you can use inter process communication to communicate process across two tegras