Running Cuda code on AWS (Amazon Cloud with Win12)

Hi everyone,

I have recently setup a g2 GPU instance on Amazon Cloud. This instance has GRID K520 with WDDM driver model ( as I see on the Nsight overview) and same info I also get from the GPU-Z utility app.

Unfortunately, my CUDA code DOES NOT run on this instance, but I dont know why.

  • I tried to use printf in my Cuda kernel
  • or to put a breakpoint for the nsight monitor

However, there is no sign that the code is running on the GPU. The code in general runs but the CUDA output is not modified by my test Cuda kernel. I have used for several years Nsight and I never seen this thing before running on Teslas, but not on K520. Did anyone experience something similar before, or could give an idea how to investigate this issue?

The Amazon instance is Win12 RC2 and my client is MACOSX. There was a claim on the web that RDP is blocking the GPUs so I have tried VNC, Slashtop and Teamviewer but nothing happened.

In case that you want to run/see the code it is in the form of a small CMake based lib, publicly available on Bitbucket at:

https://bitbucket.org/pnik073/cmakeexample

Thank you in advance,

cross posted:

http://stackoverflow.com/questions/34842250/running-cuda-code-on-aws-ec2-amazon-cloud-with-nvidia-grid-k520

because your code completely lacks any error checking, otherwise you would realise that your kernel is not running.

google “proper cuda error checking”