Running CUDA without a device Trying to use G80 totally offline


I’m trying to run an ATI X1950 (for CTM) and CUDA device on the same machine (AW9D+Core 2 Duo). What I woul d like to do is run the G80 as an offline processor, but when starting X I get a complete system hang, which I presume is due to the nvidia module and the ati driver interfering with other.
Is it a requirement that there is mention of nvidia in Xorg.conf, or a way of loading the module once the ATI card has it’s display? Or any other suggestions? I am at my wits end, and would really like to avoid having to shell out for another machine if possible!
Oh, I’m running FC6 which I know isn’t officially supported, but I have CUDA running fine when the G80 is the main device so don’t think this is the problem.
Your help gratefullly recieved!


Yes, the nvidia X driver must have ‘ownership’ of the GPU, which is best accomplished by starting X with a configuration that uses the G80 card.

Can you think of any reason why I wouldn’t be able to run an Xserver with two screens, one being rendered by the ATI card, and one by the G80?

Off the top of my head, I can’t think of any specific reasons. Is this a CUDA problem or an X problem?

Well I don’t know, and that’s why I asked what I did. I can’t get X to start (i.e I have a total system hang, requiring reboot), and it seems to be because of the CUDA driver not getting on with the ATI card (which has to be the driving display 0). It could well be that I haven’t configured my server correctly though. At least your answer offers some hope that I may yet get this machine running.

Does X start if you’re not trying to use the ATI card in the X configuration?

X will start on the G80 if the ATI card is in the second PCI slot. If the ATI card is in the first slot, I get a hang. To date I haven’t managed to get any output from the ATI card in the second slot.

This sounds like an ATI specific issue. You’ll need to contact ATI for support.


Well I’ve found that if I comment out the lines in xorg.conf to disable the composite extension, I can get the ATI card to start up, although it disables hardware acceleration because it doesn’t support composite. The nvidia card compllains that there is no device section for the PCI bus it is on - even though I set the BusID it is reporting in the CUDA device section.

If I explicitly disable composite, the whole machine hangs and requires a reboot. This makes me think it’s down to the G80. Any of this ring any bells?

Is there a way to disable an extension for a single device?

I’m pretty sure that the Composite extension is global to an X server instance and cannot be enabled on a per Device basis. None of this is CUDA related, so I’d suggest posting X configuration/usage questions to a forum more appropriate for that purpose.


Would it be unreasonable to try two X servers, one on tty7 and one on tty8 ?


I’ve tried that as well - no luck. This has wasted so much of my time I’m moving to a two box solution. Thanks for your help though.