Running Deepstream code from Putty(ssh) giving errors

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Jetson Nano
• DeepStream Version Deepstream6.1
• JetPack Version (valid for Jetson only) 4.6
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I am trying to run sample app deepstream-image-meta-test through putty terminal but every time I runs the application it gives me the following error:

ERROR from element primary-nvinference-engine: Internal data stream error.
Error details: /dvs/git/dirty/git-master_linux/deepstream/sdk/src/gst-plugins/gst-nvinfer/gstnvinfer.cpp(2288): gst_nvinfer_output_loop (): /GstPipeline:ds-image-meta-test-pipeline/GstNvInfer:primary-nvinference-engine:
streaming stopped, reason error (-5)
dlopen: Failed to load jTegra library for Tegra Acceleration

I tried changing

sink = gst_element_factory_make (“fakesink”, “fake-sink”);


sink = gst_element_factory_make (“nvoverlaysink”, “nvvideo-renderer”);

but this time this is giving me error in running this directly through my jetson nano (without headless mode).

Please provide me a solution such that i will be able to run my compiled deepstream app through ssh terminal.


Can you refer below for right setup?

Quickstart Guide — DeepStream 6.0.1 Release documentation (

I am getting this error

I have done this before by making following changes in the code:

Comment following
sink = gst_element_factory_make(“nvoverlaysink”, “nvvideo-renderer”)

and add
sink = gst_element_factory_make(“fakesink”, “fake-sink”)

Comment following
transform = gst_element_factory_make (“nvegltransform”, “nvegl-transform”);

and add
transform = gst_element_factory_make (“queue”, “queue”);

The above thing works for me earlier but again i am getting the same issue…i.e internal stream error… i am not able to identify the exact issue

If i run the code with display the the video appears and code runs fine but through ssh terminal or running at startup give me the same error…

Please help…it’s very urgent for me!

Thanks in Advance

I don’t think this is necessarily gstreamer or Deepstream related. If you are running code that requires a graphical display (such as a pipeline with an nvoverlaysink) and there is not one available, it is not going to work. That’s why switching to the fakesink which doesn’t output to a display works fine. If this is a serious need for your development process I would recommend researching how to forward graphical displays through an SSH session.

it worked by putting ./ in front of the command…
sudo ./deepstream-image-meta-test file:///filepath
this worked for me…
sudo deepstream-image-meta-test file:filepath , this was giving me issue

just by adding “./” in front it worked…still wondering the reason behind this…

If you have any idea then please tell!


Glad to know it works. Seems it is PATH issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.