Running problem... a problem on running example 'fluidGL'

I installed CUDA 1.0 on my PC and tried to run some example in CUDA SDK , but I just see that info on running ‘fluidGL’ :

NVRM: API mismatch: the client has the version 100.14.10, but
NVRM: this kernel module has the version 100.14.11. Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.
freeglut (./fluidsGL): failed to open display ‘’

What should I do? My system is rhl4.

It looks like you don’t have the actual final 1.0 release. I’d suggest downloading it again.