Running tensorflow on Jetson Xavier AGX

Hi, I am trying to bring up a Xavier AGX recently purchased from NVidia.

I have a problem with trying to import tensorflow in python3

2021-06-23 11:17:57.405430: W tensorflow/stream_executor/platform/default/] Could not load dynamic library ''; dlerror: cannot open shared object file: No such file or directory
2021-06-23 11:17:57.405665: I tensorflow/stream_executor/cuda/] Ignore above cudart dlerror if you do not have a GPU set up on your machine.

I have tried to flash the Jetson with Jetpack from the download center (after filtering the AGX):$product,jetson_agx_xavier
which Jetpack version there is 4.1.1JP and this one requires an Ubuntu host, while the new Jetpack 4.5.1 is only provided as an image for SD card.
While the tensorflow from this link looks requires jetpack 4.5

Is the only way to make the newest tensorflow (45) version? do I need an SD card?



You can use JetPack installer, part of SDKmanager, to reflash your device into JetPack 4.5.1.


Thanks for the reply.

My main issue is the incapability of the python environment to identify the position of the driver. what might be the problem with the installation process?

When I run the sdkmanager I am facing the following issue when I try to flash the Xavier, it get stucked at 99%. Any suggestions?

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.


JetPack 4.1.1 uses an older CUDA library version.
To reflash Xavier and install components from the latest JP4.5 can set up a compatible environment for TensorFlow.

In general, the flash should finish within an hour.
Do you get it to finish in the end?


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.