RX problem of ethernet of xavier in MAC-MAC mode

Hi, NVIDIA experts,
we connected the custom board and xavier with RGMII through a switch SJA1105.
The port is up with 1000M and ping each other is OK.
But in the throughput test with udp by iperf3, the RX packet lost occurs

left is the custom board, the right is the xavier.
We also tested with PC->custom switch->XAVIER , found the same issue in RX.

the changing of dts is:
phy-mode = “rgmii”;
fixed-link {
speed = <1000>;

the TX direction is normal.
please help to check this problem.
thanks a lot.

Software Version

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

Dear @43574747,
Please confirm if you are using DRIVE AGX platform?

Your topic was posted in the wrong category. I am moving this to the Jetson AGX Xavier category for visibility.

yes, it is AGX

It is possible to remove that switch and do test? Or replacing that switch to another switch.
Just to find out which one is causing the problem.

on the SJA1105 switch there were:
PORT 0: TDA4 Board
PORT 1: Xavier AGX
PORT 3: computer with ubuntu18.04
the test result is :
PC<->TDA4: both directions are normal;
PC<->xavier: from PC to Xavier is normal, from PC to Xavier is lost.
TDA4<->xavier: from Xavier to TDA4 is normal, from TDA4 to Xavier is lost.

It shows when Xavier is the receiver the UDP will be lost.
—when testing with iperf3.1.3, if adds the -l option with more than 4k bytes, it is obviously bad that is more than 90% was lost. With ‘-l 1K’ it was good performace that less than 1% was lost.
We have checked the configuration of the sja1105 switch. PORT0 and PORT1 has same configuration. So that the xavier may has something wrong.
Is there Any advise? Thanks a lot.

If connected to the HDMI and display is ON, the UDP is normal.
How could the HDMI affect the ethernet?

I don’t think this is related to software if HDMI would cause ethernet UDP to work.

Please review your hardware design first.

The hardware uses the RGMII interface, we think it is unlikely to be a hardware design problem based on the following test results:

  1. The network ports are connected, and data can be sent and received normally, and when small packets (<=2KBytes) of UDP are sent to Xavier, they can reach more than 930Mbit/s.
  2. Serious packet loss only happens when sending UDP large data packets (>2KBytes).
  3. The TCP transmission rate is also normal for large data packets (8KBytes/s), although there are retransmissions.
    So that the clock and data link on the hardware are normal.

The following is the design of the xavier hardware, please help to check:
A .What is wrong? How the design can be used normally?
B . Could you provide the hardware design schematic diagram of the Xavier’s official development board?

Please refer to design guide document and the schematic.

Hi, have you ever tested xavier connecting with MAC-MAC connection, like xavier to switch? we found this issue on xavier connecting to switch, it works fine when connecting to an ethernet phy. These two kinds of connection is the same which is RGMII.


We have some end user testing this and it worked.

Hi, This post is also testing with PHY, could you show the result of MAC to MAC mode testing, especially with the HDMI port unplugged?
And we can’t use 5.0.2 now, is there any patch for switch in the JetPack 4.6.2?

You can add similar “fixed-link” node to your jetpack4.6.2 device tree. That was what I tried to say.

Also, HDMI port is not related to EQOS driver. If that happened to your board, please review your hardware, device tree and make sure your HDMI hpd pin is in use by EQOS interrupt…

We checked our design diagram, the HDMI was not conflict with EQOS, Is there any procedure that HDMI will do to set the ethernet when it is connected?
It is emergency to solve the problem, could you please help of more advises?


Could you check if the key here is the “hotplug gpio” or the 5V power supply from HDMI that would affect your ethernet? or something else.

Hi, the Hardware has tested:

  1. cut the 5V power, the issue still exists.
  2. the Hpd was removed , the issue still exists.
  3. the i2c was removed , the issue still exists.


我想這裡的邏輯有點錯誤 我的意思是你有沒有辦法從其中這些pin裡面找到是哪一個東西會讓你的ethernet功能正常運作
這裡的意思不是叫你把全部東西移掉. 相反,你應該是一個一個測試看哪個東西加上去之後 你的ethernet就能動了(或是就壞了)

我能保證Xavier display的驅動部份一定跟ethernet的驅動沒有關係… 唯一有機會影響對方的就是可能有pin共用了
如果你的硬體部份已經確認無誤了, 那我們就得看哪一根pin影響到對方…

I think the logic here is a little bit wrong. My point is you should toggle these pins and see which one is making your ethernet functionality working (or not work). But not totally removing them.

I can guarantee that the driver for display is not relevant to ethernet driver. The only chance here may be some pin are shared here… so you need to see which pin is that first.

Hi, you can also check the signal quality. There is compliance test guide as below for your reference with which you can check if the signals quality is good enough.


with JetPack 5.0.2, we use iperf3 command to test ethernet and it’s OK with unplugged HDMI connection, I can confirm that it is a software issue. Could you give one PATCH that we can use with JetPack 4.6.1 ?