sample_object_tracker

SW version: Drive SW 8.0
OS: Ubuntu 16.04

When I run .raw file for sample_object_tracker, it generated the following error:


[29-03-2019 11:15:15] Driveworks exception thrown: DW_INVALID_ARGUMENT: Image has less planes (1) than requested amount (1).

terminate called after throwing an instance of ‘std::runtime_error’
what(): [2019-03-29 11:15:15] DW Error DW_INVALID_ARGUMENT executing DW function:
dwImageCUDA_getPlaneAsImage(&planeY, image, 1)
at /dvs/git/dirty/gitlab-master_av/dw/sdk/samples/dnn/sample_object_tracker/main.cpp:735
Aborted (core dumped)

Dear songwen.huang,
Did you check running the sample following DW documention?(NVIDIA_DRIVE_SW_8.0_References\DRIVE_Software\DRIVE AV\baggage\dwx_object_tracker_sample.html)
Are you able to run the sample with default .raw/.h264 file?

Dear songwen.huang,

Did you record the .raw file using DriveAGX recording tool?
Could you please help to check if the sample can run with drivenet sample raw file with below command?
./sample_object_tracker --input-type=video --video=…/./data/samples/raw/rccb.raw

.h264 works. The issue only occurs for .raw files.

nvidia-410, cuda 10.0, cuDNN 7.5, and TensorRT 5.0 are installed.

Dear songwen.huang,
Just to clarify, The Drive 8.0 is shipped with CUDA 10.0, TRT 4.0.3, CUDNN 7.2.2. Please check using them. Use ldd command to verify if the sample is getting linked to correct library versions.

Which .raw file are you using? Can you check with /usr/local/driveworks/data/samples/raw/rccb.raw? I am able to run without any issue

After installing DRIVE Software 8.0, there is still some path setup needed to link CUDA and GPU correctly.

in ~/.bashrc:
export PATH=/usr/local/cuda-10.0/bin:/usr/local/cuda-10.0${PATH:+:{PATH}} export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64{LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

I modify the line 735:

dwImageCUDA_getPlaneAsImage(&planeY, image, 1) -> dwImageCUDA_getPlaneAsImage(&planeY, image, 0)

This will work for all .raw files.

However, the tracking accuracy is greatly reduced after this parameter change.