Samples: ./sample_camera_tracker error

Hello !

I am struggling to launch driveworks example samples (again). In particular those related to videos & image processing. I can’t get the source of the error:

  • Command:
    sudo ./sample_camera_tracker --video=/usr/local/driveworks-0.6/data/samples/localization/camera.h264
  • Error message:
    DW_CUDA_ERROR: NVCUVIDDecode: cannot create decoder : invalid argumentDW_CUDA_ERROR: NVCUVIDDecode: cannot create decoder : invalid argument
    Unexpected exception:
    Cannot create driver: camera.virtual with params: video=/usr/local/driveworks-0.6/data/samples/localization/camera.h264

I dont understand the problem because:
-> the path to the video file provided is correct
-> Full access rights are provided to the folder and all files where the video.h264 file is located
-> I followed this DriveWorks documentation instructions : file:///usr/local/driveworks-0.6/doc/nvdwx_html/dwx_camera_tracker_sample.html

============================= ============================
*Additionally, if I run this simple command:
sudo ./sample_camera_tracker
*I get this execution message (which may be relevant):
CameraNVCUVID: no seek table found at …/./data/samples/sfm/triangulation/video_0.h264.seek, seeking is not available.
*And this error message:
Driveworks exception thrown: DW_CUDA_ERROR: Cannot create texture object : unknown error

Thank you for your help
ss1.png

Dear bcollado-bougeard,
It looks like you have not installed nvidia drivers on machine. Please check if libnvcuvid.so.1 exists on your machine.

Hi Siva,

First of all thank you very very (very) much for the simple fact of responding. I’m dying of impatience since this morning, struggling on the same problem.

Next, in fact it seems that libnvcuvid.so.1 doesn’t exist on my computer (Alleluia ?). By “NVidia drivers” you mean NVIDIA GPU drivers I guess ? I installed the one corresponding to my GPU card (GeForce GTX 570) this morning (390.59). And indeed it is defintely installed on my computed I just checked it.

May it come from from a way to old GPU card (too low compute capability ?).

Many thanks

(NB: driveworks sample_hello_world checkup in attached file, maybe you can find relevant informations there)
ss2.png

Dear bcollado-bougeard,
If the drivers are installed, you should find libnvcuvid.so in /usr/lib/nvidia-*/. Also, please check if you are able to run CUDA samples.

Dear SivaRamaKrishna,

Indeed, the usr/local/nvidia/ folder only contains the tensorrt folder.
Does it mean I installed the NVidia driver the wrong way ?
I installed the driver provided by this link : http://www.nvidia.fr/download/driverResults.aspx/134295/fr.

It appears that I installed the nividia driver in a different way that the one provided by the README.md file from the download page (because when closing the X serveur, step requested by the tutorial, the given tutorial wasn’t visible anymore). I come back to you when this source will be exhausted.

Thank you.

(NB: My apologize for the trivial problems/questions I ask, I am both new to Linux and NVIDIA drive platform)

Dear SivaRamaKrishna,

I completly removed and reinstalled NVIDIA-Linux-x86_64-390.59 drivers (following the official tutorial).
I checked that it was properly installed through the "modinfo nvidia | grep version " (it is).
I runed the Cuda-9.0 test samples with success (deviceQuery and bandwidthTest).

Still, I am able to find libnvcuvid.so on my computer: in /usr/lib/x86_64-linux-gnu/

And of course, every DriveWorks’ samples based on image/video processing keep failing with this kind of error (based apparently, and among other problem, on the incapacity to read <video.h264> video files used for those samples):
CameraVirtual: cannot retrieve framerate from video file, assume 30FPS
Driveworks exception thrown: DW_CUDA_ERROR: NVCUVIDDecode: cannot create decoder : invalid argument

I’ll try to add /usr/lib/x86_64-linux-gnu/ to path.

Added libnvcuvid to path. Nothing changes.

I will attach several screens related to my problems to this post. It will be more rich in details for those of you who are intersted in helping.

Thank you for any help.



Dear bcollado-bougeard,
Looks like you are using fermi card. You need at least Maxwell architecture GPU cards to tun these samples.

Dear SivaRamaKrishna,

Thank you for your reply.
I am using a GeForce GTX 570 (G110 processor) and indeed it is a fermi GPU card. Are you (raisonably) sure that my problems come from this ? I will be in trouble to justify a Maxwell GPU card purchase to my company if it doesn’t fix my problems.

Kind regards.

Please check Basic Hardware requirement section(page 6) in /usr/local/driveworks/doc/nvdwx_html/NVIDIA_DriveWorks_DevGuide.pdf

Dear SivaRamaKrishna,

Thanks to your final advise, all my problems are solved and I can now run every DriveWorks samples without any trouble (I installed a GeForce 1080, pascal architecture). I apologize for my negligence which made me ask you relatively trivial questions. I hope this thread will one day help some newby/lazy guy.

Many thanks.

Ben