SampleUffSSD int8 calibration segmentation fault


I’m trying to run sampleUffSSD --int8 but keep having this segmentation fault

Begin building engine…
Batch #0
Calibrating with file 0.ppm
Calibrating with file 1.ppm

Calibrating with file 49.ppm
Segmentation fault

Docker: Ubuntu16.04 CUDA9 cudnn7 nvidia driver:390.77
GPU: GTX1080ti and Titan V (two different machines with similar setup, same error)
I tried both ssd_inception_v2_coco_2017 and ssd_inception_v2_coco_2018, modified the according to this thread:
I tried different data for calibration(GTSDB, LISA dataset), same error.
I know Segmentation fault mean memory accessing problem but I have no idea on how to debug this.
The systems can run this sample with FP32/FP16 correctly.
Any advise will be appreciated.


Are you using NVIDIA TensorRT container? If so, what version of the TRT container are you pulling?

Also, can you provide the backtrace from the segmentation fault? It’d help us debug the issue.

Hi, seeing a similar issue over in this thread.

  • J.