sata problem - none hd is possible connect to

Hello,
i’m trying to connect my hd by sata, but at boot there are many fails to connect.
here there are the picture at boot up.
https://drive.google.com/file/d/0B_gDis4pWdsJejVFd3Nad0FuYmc/view?usp=sharing

any help is appreciated. i’m afraid that’s a problem of my tk1. i have checked with 2 hd and 3 cables… nothing.
tnks

Are these SSD or traditional hard drive?

Thought of another question…are you trying to boot to this drive? Or is it something which can wait for access until after boot?

I have tryed with an SSD 128 G Kingston (working fine on my laptop) and one new traditional HD western digital of 1 tera.
I don t want to boot, but only sede the HD when i boot from MMC Memory normally. Tanks

Sometimes there have been issues with solid state memory, so I’d start by using only the traditional HD. Is it correct to say that the system boots normally and without issue when no SATA drive is connected? Also, is this the original operating system/L4T that Jetson arrives with (R19.2), or has it been flashed with any other version?

The next question is where is the drive getting power from? Is it the large molex connector on the Jetson? And is the power supply used the one that comes with Jetson?

Tanks for replay.
1: yes, it is correct that when there are no SATA connection, the tk1 boots normally.
2: i have flashed the 21.2 versione originaly, not cooked.
3: the HD is powered from jetson. I hear the HD of 1 tera run, so i think the the power is OK. In my home i have 220 volts.
4: it is the originale power supply of jetson.
Tnks.

I hate to say it, but since you already tried different cables on a non-SSD drive which is known to work elsewhere, this is probably a hardware failure in the Jetson. It might be time to go for RMA. The only alternative test I can think of for more information probably won’t help…but if you have an external drive housing with USB connectivity, you could try to connect this way. Should it work it just double checks and confirms that the SATA port is failing.

Yes, you are right. and it’s interesting that i can’t install jetpack… when i run the JetPackTK1-1.0-cuda6.5-linux-x64.run file ( after changed the permission) i get two output file of encoding error… maybe there are problem about ram too… i’m so nervous…
https://drive.google.com/file/d/0B_gDis4pWdsJN0YwcDA4cVVpT00/view?usp=sharing

another check…
https://drive.google.com/file/d/0B_gDis4pWdsJTlF1WnlENkZvUms/view?usp=sharing

i wonder, how i can test ram? thanks.

Aniello, what type of machine are your running JetPack on?

My question too, just as Kangalow asks…JetPack isn’t meant to run from Jetson, the encoding error is quite unusual and has me wondering if that is the case. As far as encoding error, you could get slight increases in information running ls through base64 (not readable in the usual sense, but easily copied and pasted over the web) or cat -r (indicates control characters, but others may not show exactly):

ls -l * | base64
ls -l * | cat -r

In any case an encoding error (if run from a host it is meant to run from) would imply some rather severe corruption. On x86 machines I use memtest86 to burn in all new hardware, it might be interesting if there were some way to adapt to ARMv7. The question of memory testing won’t apply though until knowing JetPack was run in the correct environment.

EDIT: Additional note…this still wouldn’t account for the SATA error.

ok, i was using a version of ubuntu 32 bit…