Screen Flickering

I just received my jetson nano today and I plugged it into a 5v4a adapter that I had laying around and it throttled saying that there’s not enough voltage (even when I set it to 5W mode). I assume that it’s due to a bad adapter.
I then changed the adapter to a 5v 2a micro usb. Everything worked fine until I plugged in a stereoscopic camera (arducam’s). The screen then started to go black for about 2 seconds in around 10 seconds interval… I thought that there’'s probably not enough power to support all peripherals (mouse, keyboard, and the camera) so I decided to unplug the camera. The screen still keep turning on and off, so I continued unplugging all peripherals and the screen still does the same thing. I tried another 5v 2a adapter… nothing’s changed.
I then switched back to the 5v 4a adapter, unfortunately the screen still flickers. Please help.

Nvidia jetson nano b01 is the version I’m using
I am using the hdmi output and the ethernet port.
I tried using the 5v 2a adapter than comes with apple’s ipad and another one from a samsung phone

Btw this happens not just when there’s load, but also in desktop when no application is running.

  1. Do you have 5V4a power?
  2. Are you able to see any new message coming out in “dmesg” when you see the flickering?

After 4 hours of troubleshooting, it looks like the problem is with my jetson nano not being able to push enough signal power to my monitor since it needed to go through an hdmi-vga adapter. After plugging it directly to an hdmi port, it works perfectly!

Thank you!

1 Like