Screen turns black after some seconds

Hello,

I have an “ASUS ROG PG278Q” G-SYNC DP monitor that can up to 2560x1440@144Hz, connected to a GTX TITAN.

When I force the resolution to 2560x1440@144Hz, the screen turns black after 2-15 seconds.

Reproduced with 361.16, 361.18 and 361.28.

It does not happen in 2560x1440@60Hz or with 358.XX drivers version and previous ones.

To workaround this, I have to force “performance mode”.

I have a specific module parameter to force PCI-E Gen3 (Maybe there is a link, maybe not):
$ cat /etc/modprobe.d/nvidia.conf
options nvidia NVreg_EnablePCIeGen3=1

Base Board Information
Manufacturer: Intel Corporation
Product Name: DX79TO
Version: AAG28805-401

Does any other people got the same issue ? Thank you for your help.

Make sure you have laptop power management disabled for your PCIE slots on boot.

On Ubuntu,

sudo nano /etc/default/grub

If you change this file, run ‘update-grub’ afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n ‘Simple configuration’

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pcie_aspm=off
GRUB_CMDLINE_LINUX=""

If you are on Ubuntu, you can pick and choose multiple modes to use graphically, if you like.

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

You can do nomodeset, acpi=off, noapic, nolapic, etc. from a drop down box.

In any case, your deal is power management. Don’t let it mess with the power in the PCIE slot with ‘pcie_aspm=off’. Reboot. Set it to Adaptive, and try again. Pegging your vid card’s voltage and fan at 100% isn’t a solution, but you already know that.

And lastly, use 352.79 if you can. That’s stable. 361 is buggy as balls.