SD CARD ( /dev/mmcblk1p1) not recognized (solved)

Whenever I insert an SD CARD into the jetson sd/mmc slot the Jetson TK1 does not recognize the card. (fdisk -l) does not show a device and DMESG does not show any messages related to the SD CARD inserted).

Inserting the SD CARD into the USB slot (using an adapter) the Jetson TK1 shows the card as /dev/sdb1.

I’m running Tegra R21.2.0 eand Ubuntu 14.04.

Anyone familiar with this issue?

thx

Unless the card is something exotic, it should be reachable. Formatting and such might cause it to not be mountable though. What size is it? What file system type?

sd card : SanDisk Extreme 16GB, formatted as FAT32

I’m using 19r3 and I inserted some random 4GB SD card to Jetson and I do see messages in dmesg and “sudo fdisk -l” shows it too. “Fdisk -l” doesn’t print anything without sudo.

I do see some errors in dmesg though:

[ 1480.378365] mmc1: new high speed SDHC card at address 0002
[ 1480.407978] mmcblk mmc1:0002: Card claimed for testing.
[ 1480.420581] mmcblk1: mmc1:0002 00000 3.70 GiB (ro)
[ 1480.459656]  mmcblk1: p1
[ 1480.483213] of_get_named_gpio_flags exited with status 63
[ 1480.489950] avdd-hdmi-pll: 3300 mV 
[ 1480.496320] reg-fixed-sync-voltage 5.regulator: Failed to find supply vin
[ 1480.556079] reg-fixed-sync-voltage 5.regulator: Failed to register regulator: -517
[ 1480.617622] platform 5.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1480.638050] reg-fixed-sync-voltage c.regulator: Consumer c7 does not have device name
[ 1480.638289] reg-fixed-sync-voltage c.regulator: Consumer c8 does not have device name
[ 1480.655131] of_get_named_gpio_flags exited with status -517
[ 1480.655507] platform c.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1480.681976] reg-fixed-sync-voltage d.regulator: Consumer c1 does not have device name
[ 1480.682469] of_get_named_gpio_flags exited with status -517
[ 1480.696520] platform d.regulator: Driver reg-fixed-sync-voltage requests probe deferral

Fixed my problem. Problem was caused by sdcard problem (SanDisk Extreme 16GB), but this card could be used in the USB port of the jetsdon tk1 and also in other (windows/linux) systems. Other sdcards were accepted.

I tested another SanDisk Extreme 16GB which is working correctly. I reformatted the faulty card but it is still not working even I zeroed out the entire card and re-partitioned it.