SDK BSP Incompatibility

I have a Jetson NX Orin system which I have received with Jetpack 5.1 pre-installed. I want to install the Jetson SDK components but it says that 5.1 is not supported for Orin Nxs. I tried to continue with 5.1.1 components instead but the Multimedia components fails due to incompatible BSP (its expecting 35.3.1BSP but seeing 35.2.1BSP i guess).

I have SDK Manager How can I allow SDK manager to add components for 5.1 (not those for 5.1.1)?

I’ve tried SDK manager on ubuntu 18 and on 20 and that also reports that 5.1 is not available on NX Orin I tried one earlier version of SDK Manager and the same thing.

I’ve no idea how i managed to get this to work about 1.5 months ago (installing SDK components on Orin NX with 5.1 installed)

Jetpack5.1 supports Orin NX. But only Orin NX 16GB. No support for 8GB.

What did you see on your sdkmanager?

Yes it’s 16gb nx orin

Weird. Is sdkmanager still able to upgrade? I mean upgrade sdkmanager itself?

Yes I have downgraded and upgraded a few times. It’s supposed to be the most recent version currently I believe

Could you check your ~/nvidia and go to the jp5.1 folder and share me the result of ls -al?

on the host pc I presume ?( not the nx orin)

yes. Host PC.

there isnt a jetpack 5.1 folder on this host as the nx orin arrived already flashed with jetpack 5.1. I’m now trying to add the SDK components but sdk manager doesnt give the option for 5.1 on orin nx in order to create the folder.
5.1 one is available for xavier nx and agx orin though

How come a Orin NX comes with jepack5.1 flashed? Orin NX requires to use nvme to boot up. Then what did you do to your nvme if you totally cannot flash the board?

Orin NX is not like Orin AGX which has emmc…

I purchased a system which uses orin nx with a 500GB SSD card. This system appears fine and JTOP is reporting that 5.1 is installed. The hardware provider flashed 5.1 for me but didn’t add the SDK components or Deepstream.

I will check with our internal team for this issue. But this needs to wait until Monday.

BTW, could you share me the dmesg from the device(jetson)?

dmesg.txt (75.4 KB)

There is an alternative for now.

Please follow this page and use apt-get install to install nvidia-jetpack.

ok so sudo apt install nvidia-jetpack will install all the runtime and dev components that I would have used SDK Manager for? I’ve done that now and there was no error.

I think DeepStream is not included with the above command. Can you let me know what command to use to install the recommended DeepStream version for 5.1?

This was purchased from which vendor?

Please contact with the board vendor for their customized BSP first because sdkmanager tool only supports devkit.

That doesnt seem correct. SDK manager works for all the production xaviers and other orins. It just doesn’t currently show Jetpack 5.1 for the NX Orin even though this one is supported for the 16GB variant. I have even loaded it on their system a couple of months ago. Not sure why its greyed out on SDK manager now.

I don’t mind just using this if you can confirm its the same result as using SDK Manager for installing all the SDK Components?
I don’t think Deep stream is included. Whats the command for installing DeepStream?