SDK Manager: Failed to repair / update Drive AGX Nvidia SDK

Hello,

I am getting some installation errors when trying to repair and update my nvidia drive agx SDK !

I am using the SDK Manager 0.9.14.4961

These are the missed host components to be repaired : CUDA , AI (cuDNN , TensorRT), DRIVE AV, DRIVE AR, Developer tools.

List of errors:

ERROR: The .mtd file is corrupt. Start a new download.
ERROR: CUDA on Host: download error: https://developer.nvidia.com/drive/secure/drive_bundles/..../cuda-repo-ubuntu1604-10-0-local-10.0.166-410.62_1.0-1_amd64.deb failed, retrying 1…
ERROR: CUDA on Host : download ‘CUDA on Host’ failure
ERROR: CUDA on Host : undefined
ERROR: cuDNN x86 : download ‘cuDNN x86’ failure
ERROR: cuDNN x86 : undefined
ERROR: TensorRT x86 : download ‘TensorRT x86’ failure

Why all the downloaded .mtd files are corrupted (size 0 bytes)?
I tried to remove all the files and re download them again and it is the same thing !

Do you have any idea how to fix this issue ?

I have done apt-get update/upgrade and still have this issue.

Thank you,
Anfel

Dear anfel.kammoun,

I think that the issue is missing file, and with retry you may have already lost the token to download the file.
Could you please logout and re-select the SDK release to download and install as regular flow, missing files should be redownloaded correctly? Thanks.

Hello ,

Thanks for your quick answer.

That’s exactly what I did, so I started again from step 1 to download and install as the regular flow.
However, I got a different error during downloading the different files :

WARNING : cuDNN on target :

10:45:54 WARNING : TensorRT on Target : retry to connect https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb caused by Error: The .mtd file is corrupt. Start a new download.
10:45:54 ERROR : TensorRT on Target : download error: https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb failed with Error: The .mtd file is corrupt. Start a new download.
10:45:54 WARNING : TensorRT on Target : download https://developer.nvidia.com/assets/embedded/secure/tools/files/jetpack-sdks/jetpack-4.2.1-ga/JETPACK_421_b97/P3448-0000/libnvinfer5_5.1.6-1+cuda10.0_arm64.deb failed, retrying 1…

My network is working fine.
I tried to use the proxy also and it is the same output error !!

I am using the latest version of sdk manger 09.14.4961

Is there a problem connecting the SDK Manager to the network or do I need a special setup ?

Thanks.

Dear anfel.kammoun,

According to the log, it seems to download jetpack-sdk for Jetson Embedded board not DriveAGX.
Could you please select DriveAGX Dev Kit in HW configuration like below?

And please refer to below to proxy settings. Thanks.
https://docs.nvidia.com/sdk-manager/sdkm-settings/index.html

Hi,

The log files that I used here comes from another comment but it is the same error!
I am actually selecting the right target HW (drive AGX).

I solved this issue by manually downloading the required “61” (.run, .deb, …) files.

I am having another error during flashing (FLASHING FAILURE) but this is another subject and I already created a topic for it.

Maybe you can have a look and help me !

Thank you very much !