SDK Manager fails to create Jetpack 6 image

I’m having issues setting up my AGX Orin with Jetpack 6.0 DP. I attempted a WSL install but flash.sh failed with USB issues during the first BPMP reboot (while flashing bct it seems) so I gave up on that quickly. On my Fedora system I spun up the Docker version of the SDK Manager in CLI mode, but can’t even get the image to form properly–it gives an exec format error running dpkg, so I assume something is running outside/inside QEMU when it’s supposed to be the opposite. Relevant log:

What do yo have under /proc/sys/fs/binfmt_misc/?
Is CONFIG_BINFMT_MISC enabled on your kernel?

This is Fedora 39 with the SDK Manager Ubuntu 22.04 Docker image

bash-5.2$ ls /proc/sys/fs/binfmt_misc/
register  status

BINFMT_MISC should be enabled as per arch/x86/configs/x86_64_defconfig · os-build · cki-project / kernel-ark · GitLab

Do you have qemu_user installed in the Docker environment?
You need both qemu and qemu-user-static for it to work.
This should have be done by running sudo ./tools/l4t_flash_prerequisites.sh

Well you don’t run the script manually when you run SDK Manager, and presumably the Docker image NVIDIA distributes includes reasonable dependencies, but yes, I tried attaching to the container and manually installing it while it was running before flashing, but no difference. What is strange is it appears to find the aarch64 qemu installation–I don’t know why that is included in the image at all, and I certainly don’t know why sdkmanager chooses that over standard system QEMU. Seems mostly like an image config issue.

It appears dpkg is under the impression this is an aarch64 image, which it should not be–if it is, it should be denoted as such on the site (and configured properly with Docker architecture stuff)

So you still got nothing under /proc/sys/fs/binfmt_misc/ insider your Docker?

The situation is that you populate these Debian packages in L4T BSP by chroot into the rootfs with the help of QEMU, so you are indeed running an aarch64 binary on an x86 host PC.

I’m not that familiar with Docker, but maybe some kernel stuff is shared between host and Docker environment. Can you try if installing qemu and qemu-user-static on your Fedora host makes it work?

I did not anticipate that working haha but it got substantially further. Now, it seems qemu is reporting a segfault while setting up libc-bin. I wonder if the version mismatch between host and container is causing qemu to flip out…I’ll play around with it more.


Yea so confirmed the theory–qemu has to be installed on the host, and the version needs to be compatible–Ubuntu 23.10 worked flawlessly but Fedora 39 failed with the above libc install segfault. Thanks for the help!

1 Like

It would be interesting to hear back on any flavor of Linux distribution you try with when it fails or succeeds. I used to work only on Fedora, and command line tends to work on a lot of distros, but JetPack 6 adds some new flexibility. It’s going to be interesting to see what people get to work with that.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.