SDK Manager GUI --disable-gpu seems to be an unknown argument

Hi,

The SDK Manager goes blank after I login.

I did a little bit of googling and I found that disabling the usage of the GPU for Electron application is the solution.

But I get an error:

$ sdkmanager --disable-gpu

Error: unknown argument ‘–disable-gpu’

I saw this post from NVIDIA: https://devtalk.nvidia.com/default/topic/1052707/general/drive-development-platform-xavier-pegasus-sdk-manager-gui-doesn-t-show-up-in-host-linux-pc/post/5347633/#5347633

Where you have an example with --disable-gpu.

So I am confused on why it is not working for me.

So is there any other way of disabling the GPU usage for SDK Manager?

Here are some details of my OS:

Distributor ID: Debian
Description: Debian GNU/Linux bullseye/sid
Release: testing/unstable
Codename: n/a

I could always change the Linux distro if that helps.

Thanks in advance for your time and help on this issue.

Hi jnyl117,

Please help change to ubunut 18.04. Here are the host system requirements. Thanks!

Hi,

Thank you for responding so fast.

I just tried it on Ubuntu 18.04:

Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

I am having the same issue.

Again, is there a way to disable gpu for the SDK Manager?

I saw it in one of your posts on this forum.

But it says:

Error: unknown argument ‘–disable-gpu’

Is there a config file or some other way I could disable the gpu?

Thanks

Could you try if running with “sdkmanager --spectron --disable-gpu” helps on this issue?

When reproduce the issue, could you also provide the result of ‘ps aux|grep sdkmanager’? Thanks!