SDK Manager Installation


I am trying to install the software (sdkmanager).
Unfortunately the installation always stops at “Target Components: Drive OS: OSS and NV packages” at ~ 99 %
I also read the topic from madergona (
So i also started the installation with sudo, but nothing changed. I also can’t upload the log-file,because the file is empty. This is a short extract of the sdk-manager terminal:

14:34:21 INFO : OSS and NV packages : Verifying archive integrity… All good.
14:34:22 INFO : OSS and NV packages : Uncompressing drive-t186ref-linux-…Extraction failed.
14:34:22 INFO : OSS and NV packages : exit status 143
14:34:22 ERROR : OSS and NV packages : Failed to install with ‘NV_INSTALL_SERVICES_BYPASS=1 NV_INSTALL_TEST_MODE=1 /home/nvidiahost2/Downloads/nvidia/sdkm_downloads/ --nox11’ command
14:34:22 INFO : OSS and NV packages : InstallUtil returns: exit status 143
14:34:22 ERROR : OSS and NV packages : command terminated with error

Hope you can help me. Thanks!

Best regards

Hi Toby,


sudo apt-get clean

and try again. Looks like your apt dependency tree is broken.

  • Fabian


We are in a similar situation.
The installation always stops at “Target Components: Drive OS: GNU Toolchains” at ~ 98.9 %

But not found error at sdk-manager terminal.

22:05:58 INFO : GNU Toolchains : Found file /home/clarion/Downloads/nvidia/sdkm_downloads/ with correct checksum, skip downloading.
22:05:58 INFO : GNU Toolchains : download ‘GNU Toolchains’ success
22:05:58 INFO : GNU Toolchains : Start to install ‘GNU Toolchains’

I would be grateful if you could help me.

Best regards.

Hi Yuya,

thanks for reaching out to us. We are aware of this issue and I am working on it just right now.

All I can tell you so far is the bar does not reflect the actual progress, rather see it as an approximation.

The error occurs in both of your cases iff the flashing process is taking longer than the ‘approximated’ time.

Will reach out to you as soon as I have a solution.

  • Fabian


I got the same issue. Is there a solution available?


Hi guys,

sorry for the delay, let me explain you the reason for your problem and propose a solution for it:

Reason: You have installed DRIVE using $sudo using the old SDKM. The SDKM is basically creating three folders which are

  • ~/.config/sdkmanager to manage the GUI part,
  • ~/.nvsdkm for all your user settings, logs, profiles, etc. and
  • ~/nvidia for the DRIVE image itself.

Now imagine you created one of them using $sudo and now trying to work with this folder structure using user privileges with our new SDKM: Errors regarding those three folders may occur. E.g. if you want to start the new SDKM but your old $sudo installation permits you from accessing the GUI-needed folder structure, the GUI will not show up. Another case might be that you are not able to create any log files or save packages.


  1. Get user ownership for GUI cache files
    sudo chown owner-user:owner-group ~/.config/sdkmanager/ -R
  2. Get user ownership for SDK Manager user profile folder
    sudo chown owner-user:owner-group ~/.nvsdkm/ -R
  3. Remove old target releases folders created with wrong owner
    sudo rm -rf ~/nvidia/nvidia_sdk
  4. Remove parent folder - only if empty.
    sudo rmdir ~/nvidia/
  5. If not empty - take ownership
    sudo chown owner-user:owner-group ~/nvidia/ -R

I hope this makes it clear and you are good to go now.

  • Fabian

Hi Fabian,

Thank you for your reply.
However, your solution could not solve my problem.

For your information, this is my first time to install SDKM(Ver.0.9.9-2351),
so I do not have an old SDKM.

Hope you have another solution.

Best regards.

Hi Iwase,

I am assumung you are running Ubuntu 16.04, therefore please provide me with some more information about your system.

@Mirko and @Tobias, how are you two guys doing with your issue - did it resolve?

  • Fabian

Hi Fabian,

the workaround doesn’t change anything.
I just downloaded the SDKManager this morning (newest version). I did the installation just as described in the devzone.



Hi all,

depending on your $locale settings you might expect an error when entering your password filed in the logs; that is does not match and you do not have the permission to install. Check your setting with:


Depending on your special characters plus defined $locale, the SDKM might not consider your user settings yet - this will be fixed ASAP.

For now, set your $locale settings to en_US.UTF-8 and try again. As written above, the SDKM will receive an update very soon, so then you will not need to do this anymore.

  • Fabian

Hi everybody,

as Fabian mentioned above, I changed the locale to US setting and now the installation worked for me.

Thanks for your support Fabian !

Best regards