SDK Manager is saying, "Board not Detected"

I bought a Jetson Nano developer kit B01 - 4GB recently. I went to Nvidia website and flashed the SD card Image onto a SD card and inserted it into the slot under Heat sink and tried to boot it using monitor.
It booted successfully and asked for update of the software as well. Then i tried downloading the debian package of sdk manager, and run on terminal. But, a few dependencies were not fulfilled, the reason for which i think, the package that i downloaded was meant for amd64 machine. But the jetson nano has a arm64 architecture. Please help!!

JetPack/SDK Manager is never run on the Nano or any Jetson. You are correct that it is the wrong architecture.

What happens is that if you boot your Jetson in recovery mode, then the micro-B USB turns the Jetson into a special USB device understood only by a custom driver (conveniently known as the “driver package”). This package runs on a desktop PC architecture, e.g., Ubuntu 18.04 PC. Jetson’s don’t have a BIOS (nor any embedded system), and thus cannot self-flash.