SDK support for Orin NX

Hi, when will the SDK support the Orin NX module imaging.

I see that there is emulation mode on AGX for Orin NX, can that image be used for the Orin NX module too ?

What is the recommended procedure for flashing image to Orin NX with NVMe SSD

regards , rapidproto

We will have the next JetPack release to support Orin NX in coming weeks, relevant get start doc will be posted together, please wait for our announcement. Thanks

Thanks Kayccc, looking forward to it

Hi Kayccc,

I tried manually flashing the Orin with NVMe using the procedure in this document…

and files located here…

The file system is created OK and the flashing procedure works without error, until step 3, reporting that it is waiting for device to boot. Regardless of whether I reboot manually, with or without jumper, it never gets past step 3.

Can you let me know if there is anything I am missing here…

I followed this procedure…
$ tar xf Jetson_Linux_R35.2.1_aarch64.tbz2
$ sudo tar xpf Tegra_Linux_Sample-Root-Filesystem_R35.2.1_aarch64.tbz2 -C Linux_for_Tegra/rootfs/
$ cd Linux_for_Tegra/
$ sudo ./
$ sudo ./tools/

and flash the target using this command…

sudo ./tools/kernel_flash/ --external-device nvme0n1 -c ./tools/kernel_flash/flash_l4t_external.xml -p “-c ./bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 p3509-a02+p3767-0000 internal


Try this command:

sudo ./tools/kernel_flash/ --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 p3509-a02+p3767-0000 internal

As for me, it works.

Thank you for your reply Dimaz, I can confirm that this command works now, my problem was not removing the recovery jumper, so it was not able to boot after imaging and timed out.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.