sdkmanager hangs and retrying never continues on

OS: Ubuntu 18.04 LTS (multiple machines and networks)
Jetpack: 4.2.1 (Rev 1)

I have been trying to install the developer tools from Jetpack 4.2.1 (Rev. 1) Linux for Jetson AGX Xavier for 3 days now and the install hangs every time on the following stage (truncated from the terminal):

DEBUG : NVIDIA Nsight Graphics : running command < .............

I have followed all instructions from here, but the same behavior is observed every time I try to install. Has anyone else experienced this? Any ideas what it might be?

The line “invalid character ‘d’ after object key:value pair” looks really suspicious. In digging through the opt folder on my pc, it looks like the sdkmanager is trying to call InstallUtil, which is not to be found at the path referenced.

Hi josephwdinius,

On your host Ubuntu machine, what’s “multiple machines and networks” means?

There are three host machines that I have tried, all running ubuntu 18.04 - personal laptop, work laptop, and home workstation.

“Multiple networks” means I have used the networks at both my home and office.

All combinations lead to the same hanging condition in the sdkmanager at the Nsight Graphics install stage.

Thanks for your response.

Hi josephwdinius,

Please share your host machine information with below two commands:

$ lsb_release -a
$ uname -a

Thank you for your response.

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:        18.04
Codename:       bionic
uname -a
Linux jdinius-Blade 4.18.0-25-generic #26~18.04.1-Ubuntu SMP Thu Jun 27 07:28:31 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Hi josephwdinius,

Can you please zip and attach the ~/.nvsdkm directory for more investigation?

EdwardZhou, I have attached the requested zip file. Thanks for your attention. (597 KB)

Hi josephwdinius,

Sorry for the late reply. I checked the logs but couldn’t root cause the error. I guess the error might be terminal environment related. I might need your environment settings in terminal for more investigation, thus sent you a private message for this.

Update 8-19: I have tried running the sdkmanager in terminal with profile and rc settings removed with the following command:

bash --noprofile --norc sdkmanager

and the same behavior is observed.