SDKManager - installation failed

Hello everyone!

I have a Jetson TX2 developer board and I would like to flash it with SDKManager.
I followed the GUI steps, the download went correctly, but I got some errors during the installation, and it failed.
I took some screenshot of the GUI errors, but I am a new user, so it is not allowed me to upload multiple pictures, so the last two error lines are below. It is not possible to copy the error messages from the GUI.
About my host machine:

  • Ubuntu 18.04.4 LTS
  • 4GB RAM (when SDKManager launched, I got a warning window about 8GB is required, but it was allowed to continue)

Please help me, how to solve the problem. Thank you!

The last two error lines are:

ailure
20:15:02 ERROR : Multimedia API : Flash skipped due to component(s) download/install failure

I don’t know if 4GB of RAM would cause failure, but there are checksum failures, and those are guaranteed to be trouble. Is there anything unusual about your host PC’s networking or hard drive? Perhaps if the disk was close to full some images could be truncated (and cause a bad checksum). If networking is bad, then this too could cause corruption. It is really a stretch, but I suppose if the system was swapping out too heavily and dropped network buffers because data was coming faster than it could store, perhaps this too could cause file corruption upon download. You can see about disk space via:
df -H -T ~
(the tilde, ‘~’, is the home directory of your user)

Thank you for your reply!
When I first tried the installation, there wasn’t enough space in my hard drive. (My SSD has a Windows and a Linux partition, the Linux has 2 more partitions). I modified the partition of the hard drive, so there is enough space now. I ran the command you sent and I attached the result as a photo. I think everything is ok with the hard drive.
About the network, there is nothing special, it is a regular home network.

Do you have any suggestions what to check, or modify?

Thank you!

Screenshot from 2020-06-05 22-13-12

If your disk space is enough (and it looks like it is), then download issues are most likely. Removing the old download content and starting again would be useful since it might have been a temporary issue.

Deleting the ~/nvida/ and ~/.nv/, and then running SDKM again would recreate content and not depend on stale cached network content. Some content is in “~/Downloads/nvidia/sdkm_downloads/”, but I don’t think you would have to worry about that and running SDKM again after the other content is deleted would imply downloading that other content again (at least if checksums are wrong and you had wrong checksums).

I would be very careful about doing a forced recursive delete, but if you are certain you are in the correct location and name the correct delete target, it would go something like this:

cd ~/nvidia
pwd
sudo rm -Rf ./*
cd ~/.nv
pwd
sudo rm -Rf ./*
cd
# Now run SDKM again and try to get a good download

If you still see checksum errors, then it might be time to look closer at the manifest.json file and your networking to the addresses there.

I removed data with built-in button in SDKM, then I re-installed SDKM. I selected JetPack 4.2 instead of 4.4 and it installed successfully.

Thank you so much!