SDKManager Sudo validation failed


I’m trying to use the SDKManager to flash a DRIVE_PX_2_AutoChauffeur. I have installed all the target components before and just want to flash the dpx now.

So I’m using the manager to select the components I want and continue to step 2 and accepts the license agreements. When I click to continue to step 3 I get the dialog to enter my password and it gets accepted (If a try with a wrong one I get an error) but then nothing happens.

I checked the log and found that I have an error on completeSetup failed Sudo validation command failed that is weird because I could install everything a couple of weeks ago, but then I didn’t want to flash any target.

********************** Running install for bundle DRIVE_OS_5.0.10.3_SDK_with_DriveWorks_Linux_for_DRIVE_PX_2_AutoChauffeur time: 24/04/19 14:48:50 **********************
2019-04-24 14:48:57.412 - error: completeSetup failed Sudo validation command failed
2019-04-24 14:48:57.412 - error: install process failure Sudo validation command failed
2019-04-24 14:48:57.414 - info: 

********************** Completed install for bundle DRIVE OS SDK with DriveWorks Linux for DRIVE PX 2 AutoChauffeur time: 24/04/19 14:48:57 is succeeded: false

I have tried to reinstall the SDKmanager but I still get the same result. I also tried to uninstall driveworks from the manager to be able to reinstall it, but I can’t do that either.

Any ideas how to solve this?

Jesper (260 KB)

Dear JesperEricsson,

Could you please run following command in terminal, and let us know what is the output? Thanks.

sudo -k && sudo -v -S ; echo $?

Hi SteveNV,

The output from sudo -k && sudo -v -S ; echo $? is 0

Dear JesperEricsson,

There are two way to fix this symptom.

  1. When there is special character in user’s password, it will cause such error when validating password in terminal.
    Current workaround is to not use or change the special character in password, then retry.

  2. Our new SDKM client fixed this issue, could you please use the new client to install?



The password thing explains it, I had changed my password between the first time I used the SDKM and when I tried flash the dpx.

By changing it back I could run all the steps and get the Flash option.

Thanks for the help


This helped me too !

Thank you,