SDKmanager v1.3.0 won't launch

Hi,

I want to use the whole jetpack software to flash an image stored on a host ubuntu pc onto a Jetson Xavier.
I downloaded sdkmanager_1.3.0-7105_amd64.deb from the official website then ran the command
sudo apt install ./sdkmanager_1.3.0-7105_amd64.deb
as instructed. The installation of the sdkmanager seems to go through, however, if I then use the command
sdkmanager
nothing happens. The terminal waits for approximately 5 seconds then returns a blank line and nothing shows up.
I tried using sdkmanager --enable-logging -v=1but instead of returning a proper error log I get :
Error: unknown argument '--enable-logging' Error: unknown argument '--v'
As a result I can’t go through with installing the whole jetpack software.

Also it might help anyone coming across this that I tried installing the sdkmanager v0.9.12 linked with JetPack4.3, the sdkmanager command does open the GUI but after inputting my credentials and password, I get No SDK available for your account and it won’t change no matter how many times i restart the sdkmanager (as suggested here No SDK available for your account )

My system:
Ubuntu 18.04.5 LTS
Nvidia Driver Version: 440.95.01
CUDA Version: 10.2
Attempting to install JetPack4.4

Hi t.velon,

Can you please try following steps?

  1. Install SDK Manager 1.3,
  2. Run sdkmanager command in a terminal window.
  3. Package then attach ~/.nvsdkm directory for more investigation?

Hi,
The correct command line should be:

sdkmanager --spectron --enable-logging -v=1

Hi,
Thank you for the prompt reply.
This command line does indeed output some log, but I’m having trouble figuring what is wrong in there.

err_log.txt (13.7 KB)

Hi,
Thanks for replying on such short notice.
Here is the nvsdkm folder zipped.

nvsdkm.zip (2.4 KB)

HI again,
I found a solution to my problem thanks to your advice.
Turns out I had made one installation of the SDKmanager 1.2 that wasn’t setup properly but when I removed it, the .nvsdkm folder remained there. Due to that, every other version of the software that I was trying to install would see this folder and that would lead to a silent error.
I just had to delete my old .nvsdkm folder located in root
Thanks for leading me on the right track.