Sdkmanager won't flash nx devkit nvme

is there any easy way to flash nxdevkit with nvme, without sdcard with sdkmanager? without sdkmanager from terminal?
is there any easy way to flash nx devkit with sdcard using sdkmanager? without sdkmanager, from terminal so that it boots from nvme?
I have tried several combinations none worked to boot from nvme. but only simple sdcard boot.

Hi _av,

If your are using Jetpack5.1(R35.2.1), you could refer to the Example 2 of Workflow 11 in Linux_for_Tegra/tools/kernel_flash/README_initrd_flash.txt

If you still can not flash successfully, please help to provide the detail steps (every commands you run) and flash log from host.

Thank you for following up
do you suggest that the Example 2 of Workflow 11
can be applied as is non modified to nx devkit without sdcard with nvme drive? with modification of xml file ? Without modification of xml file? with modifications of arguments of the command line execution? without modification?

we tried multiple times. the step 3 did not seem to complete
it would say error flashing to external [app]
how do you need error logs gathered?

the Workflow 11 example 2 has 3 steps each of them asks to put nx into the recovery mode:

1. Put the device into recovery mode, then generate qspi only images
2. Put the device into recovery mode, then generate a normal
filesystem for the external device:
3. Put the device into recovery mode, then flash both images:

does it imply the recovery mode needs to be triggered 3 times?
does it imply that recovery mode doesn’t need to be triggered 3 times?
does it imply that the proposed method requires 3 manual reboot? doesn’t it imply that?
In the file flash_l4t_external.xml does just one value num_sectors need to be substituted with the one of the nvme? or multiple values across the file? given num sectors of nvme is 976773168 with 512 sector size ?

Reference steps

tar xf Jetson_Linux_R35.2.1_aarch64.tbz2 
cd Linux_for_Tegra/rootfs/
sudo tar xpf  ../../Tegra_Linux_Sample-Root-Filesystem_R35.2.1_aarch64.tbz2 
 cd ../..  #Changing to script folder
 sudo tools/
 sudo ./
 cd tools
 sudo ./ -u nvidia -p nvidia -n nvidia-host 
--accept-license --autologin

Putting nvme nx devkit into the recovery mode once then applying the reference example

sudo ./tools/kernel_flash/ --no-flash jetson-xavier-nx-devkit-qspi internal
sudo ./tools/kernel_flash/ --no-flash \
      --external-device nvme0n1p1 \
      -c ./tools/kernel_flash/flash_l4t_external.xml \
      --external-only --append jetson-xavier-nx-devkit external
 sudo ./tools/kernel_flash/ --flash-only

based on post by [ManuelLeiva]

@KevinFFF Comments?

Yes, every step is for different purpose, you should enter force recovery mode before each step.

In this workflow, it seems no need to care about the sector and NVMe size.

Could you help to provide the flash log from host side for further check?

it worked
thank you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.