Secure Boot on Jetson TX2

I am following https://github.com/Trellis-Logic/secureboot-tegra guidelines to enable secure boot on my NVIDIA Jetson TX2 board.

After flashing, I booted my TX2 to verify it. TX2 booted successfully. However, I got these messages during the boot on my monitor:

tegra-xusb-padctl 3520000.xusb_padctl: failed to setup XUSB ports: -517
Please complete system configuration setup on desktop to proceed…
vdd-1v8: voltage operation not allowed
sdchi-tegra 3440000.sdhci: could not set regulator OCR (-1)

After the boot of the system, I can see a System Configuration window, but my mouse and keyboard are not working and hence I can’t configure anything. I suppose this is because of XUSB ports error.

What is the workaround for this? Any insight will be highly appreciated.

hello vishal.trbwins,

had you verified your mouse and keyboard works with default image?
did you using a usb-hub? please have a try to connect mouse/keyboard to TX2 directly.
you should also review Secureboot session for some details of enabling secure boot.
thanks

I have a similar issue with XUSB error after flashing my device and the USB ports not working. I though am not trying to do secureboot. Here is a link to my issue Jetson TX2 Freezes at System Configuration Screen. I have tried connecting my key board and mouse with not effect. I have tried connecting the keyboard directly. I have tried various combinations of USB cable being connected during boot or after boot etc. No luck and I cannot, of course, connect to the device via the micro USB. At this point it is sort of a brick if there is now way for me to provide input to it.