Seeking Help: CUDA Device Not Detected, Unable to Run CUDA Programs

Dear members and experts of the official NVIDIA forum,

I am a passionate student who loves learning and exploring artificial intelligence. Recently, I tried to install and configure CUDA on my computer for deep learning development. However, I encountered some issues during the installation process and I’m hoping to seek your help and guidance here.

I followed the guidelines on the official website and downloaded CUDA 12.2 along with the corresponding cuDNN version ( The installation process completed without any errors, and I verified the CUDA compiler version using nvcc -V, which confirmed that CUDA was successfully installed with version 12.2. Additionally, my graphics driver version is 536.67, which is the recommended version by NVIDIA.

However, when attempting to run deviceQuery.exe and bandwidthTest.exe, I encountered the following errors:

Copy code
deviceQuery.exe Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 100
→ no CUDA-capable device is detected
Result = FAIL

[CUDA Bandwidth Test] - Starting…
Running on…

cudaGetDeviceProperties returned 100
→ no CUDA-capable device is detected
CUDA error at C:\dvs\p4\build\sw\rel\gpgpu\toolkit\r12.2\demo_suite\bandwidthTest\ code=100(cudaErrorNoDevice) “cudaSetDevice(currentDevice)”
I have carefully checked the environment variable configuration and found no issues. I also attempted to reinstall CUDA and the graphics driver, but the problem persists.

Therefore, I am sincerely seeking your help and guidance. Could you please advise me on how to resolve this issue and enable CUDA to work properly on my system? Are there any other configurations or settings that I need to pay attention to?

Here are the details of my system and hardware:

Operating System: Windows 10
Graphics Card: 3060
Graphics Driver Version: 536.67
CUDA Version: 12.2
I greatly appreciate your patience and assistance, and I hope you could provide me with some advice and guidance to enable me to use CUDA for deep learning development smoothly. Thank you!

Best regards

You need a NVIDIA GPU for any of this to work correctly.

Thank you for your response! My graphics card is NVIDIA GeForce RTX 3060. My issue is that even though I installed CUDA 12.2 and cuDNN, I encountered an error when running bandwidthTest.exe. I know my graphics card supports CUDA, but I still can’t use it correctly. I hope you can provide me with some advice and assistance.

There is an installation problem of some sort.

Is this on a laptop?
Are you running these tests on native windows or on WSL2 ?

Thank you very much for your response and advice. Regarding my installation issue, I confirm that there is some kind of installation problem.

To answer your questions, I am running these tests on a desktop computer, not a laptop. The tests are performed on native Windows, not on WSL2.

Regarding the installation of CUDA, I used the official NVIDIA provided CUDA 12.2 toolkit installer. However, I still encountered the ‘API mismatch’ error. I have checked the ‘/usr/local/’ directory to ensure that only one version of CUDA is listed, and the symbolic link is set to the desired version. Additionally, the CUDA path is correctly included in the ‘PATH’ and ‘LD_LIBRARY_PATH’ environment variables. The configured repositories in the ‘/etc/apt/sources.list’ file also point to the correct URLs.

If you have any further suggestions or need more information about my situation, please let me know. Thank you again for your response and attention, and I look forward to any further assistance you can provide."

This doesn’t make any sense. If you are on native windows, there isn’t anything that involves paths like /usr/local. That is for linux, not windows.

It’s not clear what you are doing but you are now mixing windows an linux terminology, and that cannot possibly be correct. Furthermore this is the first time in this thread you have mentioned an “API mismatch” error. I’m not sure what that is.

this document describes proper setup steps to use CUDA on native windows

I’m sorry for the inconvenience caused. My English is not good, so I’m using ChatGPT to translate and summarize my words. Sometimes there may be deviations, and I’ll carefully check the replies. My problem is: I have an RTX 3060 graphics card, with the latest version of the graphics card driver, and I downloaded CUDA 12.2 from the official website, and the installation process seemed to be successful. When I run nvcc -V , it shows the correct CUDA version information: “nvcc: NVIDIA (R) Cuda compiler driver, Cuda compilation tools, release 12.2, V12.2.91, Build cuda_12.2.r12.2/compiler.32965470_0”. However, when I try to run deviceQuery and bandwidthTest , it gives me the error “no CUDA-capable device is detected.” I’m a beginner, and I really appreciate your help. Thank you again for your response.

My Windows version is Windows 10 Education, version 22H2.“I checked the official website, and my system version is supported, so I am very confused and cannot find the reason.”