Seen by SDKManager, LED on when plugged, SD card flashed but no boot

Hello, I have a problem with my Nvidia Xavier NX Developer Kit board.

I have been able to flash it twice before and it was working. I uninstalled OS from SDKManager and now when I plug it, the led goes on, it is detected by sdkmanager but it doesn’t boot. if I run lsusb I can see it too.

edit: I tried to flash 2 different SD Cards and the result is the same, either with the dd command or with Etcher

Could you explain what is “I uninstalled the OS from sdkmanager?” What did you do here?

From the SDK I selected Uninstall / Repair option then did “Uninstall” in front of “Target components (Jetson Xavier NX [Developper Kit Version])” with the board connected

I don’t think uninstall really did anything to your board… it seems only remove the folder on your host but not your jetson device.
Have you flashed your cards with sdkmanager?

I tried flashing them using dd, Etcher and the sdkmanager, where dd worked at start

Hi,

Then I think we should check the log. If it “suddenly” cannot work, it is possible a hardware defect.

I used flash.sh as :

sudo ./flash.sh jetson-xavier-nx-devkit mmcblk0p1

and everything got back to normal, thanks

1 Like

Hi,

This does not make sense because sdkmanager is using flash.sh too.

Anyway, glad that it is resolved.

Thanks romian.goasdoue for the post and the follow up solution.

I also had the same issue, after trying to re flash the NX using

Sdkmanager it would not boot and new SD Cards did not work.

When trying to re flash the Jetson with sdkmanager it would always

stop at 99.0%.

After reading your posts I was able to get the unit up and running

Pretty quickly.

Thanks!!!