Segmentation fault of TensorRT 8.0.1 when running nvinfer1::createInferRuntime

Description

I am able to run this code without ROS when i’m trying to run it with ROS noetic i’m facing this seg fault error

Reading symbols from devel/lib/LIBFCW/LIBFCW…
(No debugging symbols found in devel/lib/LIBFCW/LIBFCW)
(gdb) r
Starting program: /full_system/home/anirudhn/object_and_lane/mediatech_LIBFCW/LIBFCW_FINAL/ros/devel/lib/LIBFCW/LIBFCW
warning: Probes-based dynamic linker interface failed.
Reverting to original interface.
[Detaching after fork from child process 11600]
[Detaching after fork from child process 11603]
[Detaching after fork from child process 11604]
[Detaching after fork from child process 11606]
process 11596 is executing new program: /full_system/home/anirudhn/object_and_lane/mediatech_LIBFCW/LIBFCW_FINAL/ros/devel/lib/LIBFCW/LIBFCW
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/usr/lib/x86_64-linux-gnu/libthread_db.so.1”.
[New Thread 0x7fffbea90000 (LWP 11607)]
[New Thread 0x7fffbe28f000 (LWP 11608)]
[New Thread 0x7fffbd72b000 (LWP 11609)]

Thread 1 “LIBFCW” received signal SIGSEGV, Segmentation fault.
0x00007fffdf9fd76b in ?? () from /usr/lib/x86_64-linux-gnu/libnvinfer.so.8
(gdb) bt
#0 0x00007fffdf9fd76b in ?? () from /usr/lib/x86_64-linux-gnu/libnvinfer.so.8
#1 0x00007fffdf9e5ab0 in ?? () from /usr/lib/x86_64-linux-gnu/libnvinfer.so.8
#2 0x00007fffdfa14f93 in ?? () from /usr/lib/x86_64-linux-gnu/libnvinfer.so.8
#3 0x00007fffdfa1509d in createInferRuntime_INTERNAL () from /usr/lib/x86_64-linux-gnu/libnvinfer.so.8
#4 0x000055555563964d in nvinfer1::(anonymous namespace)::createInferRuntime(nvinfer1::ILogger&) ()
#5 0x0000555555639d51 in V8_ObjectDetection::deserialize_engine(std::__cxx11::basic_string<char, std::char_traits, std::allocator >&, nvinfer1::IRuntime**, nvinfer1::ICudaEngine**, nvinfer1::IExecutionContext**) ()
#6 0x000055555563973a in V8_ObjectDetection::V8_ObjectDetection() ()
#7 0x000055555558f35c in FCW::FCW() ()
#8 0x000055555557c9a2 in __static_initialization_and_destruction_0(int, int) ()
#9 0x000055555557d277 in _GLOBAL__sub_I_g_speed ()
#10 0x00005555556cacdd in __libc_csu_init ()
#11 0x00007fffde121010 in __libc_start_main (main=0x55555557b283 , argc=1, argv=0x7fffffffd768, init=0x5555556cac90 <__libc_csu_init>,
fini=, rtld_fini=, stack_end=0x7fffffffd758) at …/csu/libc-start.c:264
#12 0x000055555557a9ce in _start ()

Environment

TensorRT Version: 8.0.1
GPU Type: RTX 3090
Nvidia Driver Version: 525.147.05
CUDA Version: 12
CUDNN Version: 8.2.2
Operating System + Version: 20
Python Version (if applicable): 3.8
TensorFlow Version (if applicable):
PyTorch Version (if applicable):
Baremetal or Container (if container which image + tag):

Hi @anirudh.nagpal ,
This forum talks about issues related to Tensorrt.
Request you to reach out to concerned forum.

Thanks.