"Segmentation fault" with cheese

I just received my Xavier NX and flashed and attached an USB camera and I get with cheese the error message “Segmentation fault”.

But gst-launch-1.0 v4l2src ! xvimagesink works fine !

Does anyone know how to solve that problem?

You may try this patch. It fixed issues with guvcview or qv4l2, but not checked for cheese.

hello ismet.guelkanat,

please also share the JetPack release version you’re using.

I just downloaded the sd card image 4.51 from the “getting started” site for Xavier NX, as I said.

I Have already tried the update and upgrade as well as dist-upgrade but nothing helped. I can see the /dev/video0 device and the USB is working fine (at least mouse and keyboard are working w/o any problem).

If I start cheese with sudo, then I see for a second a new window (at least the frame of the window) of cheese application then it disappears and I get again the error message. I thought that it might have something to do with the privileges.

@Honey_Patouceul The application guvcviewer also generates the segmentation fault error even though the v4l2 works fine at least the command “gst-launch-1.0 v4l2src ! xvimagesink”

hello ismet.guelkanat,

could you please access the attachment via this thread, Libv4l2_nvargus.so source code - #19 by JerryChang
please replace /usr/lib/aarch64-linux-gnu/tegra/libv4l2_nvargus.so with the attachment, you may perform a warm-reboot (i.e. $ sudo reboot ) to make the changes take effect.

Hi thank for the help… it worked to capture pictures from the attached USB camera

But if I try to access the camera(s) attached to the CSI port, i get the message that no camera are available.

here is my pyton code:

import cv2

width = 800
height =600

camSet_str = ('nvarguscamerasrc sensor-id={} ! ’
'video/x-raw(memory:NVMM), width=1920, height=1080, framerate=60/1, format=NV12 ! ’
'nvvidconv flip-method=2 ! ’
'video/x-raw, width={}, height={}, format=BGRx ! ’
'videoconvert ! ’
'video/x-raw, format=BGR ! ’

while True:
_, frame = cam.read()
cv2.imshow(‘myCam’, frame)
if cv2.waitKey(1)==ord(‘q’):

and that is the error message I get:

Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:645 No cameras available

(python3:8932): GStreamer-CRITICAL **: 11:50:19.843: gst_mini_object_set_qdata: assertion ‘object != NULL’ failed
[ WARN:0] global /home/nvidia/host/build_opencv/nv_opencv/modules/videoio/src/cap_gstreamer.cpp (933) open OpenCV | GStreamer warning: Cannot query video position: status=0, value=-1, duration=-1
Traceback (most recent call last):
File “/home/iguelkanat/Desktop/PyPro/OpenCV/PiCam.py”, line 19, in
cv2.imshow(‘myCam’, frame)
cv2.error: OpenCV(4.1.1) /home/nvidia/host/build_opencv/nv_opencv/modules/highgui/src/window.cpp:352: error: (-215:Assertion failed) size.width>0 && size.height>0 in function ‘imshow’

the command: ls /dev/video* says that there is no such file or directory.

Thx for the help

hello ismet.guelkanat,

it should be bayer sensors that going through CSI port. would you like to enable cheese to stream bayer sensor? this is not working, please also check Camera Architecture Stack for reference.

Sorry but I don’t get it. The Xavier NX has 2 ports to connect CSI cameras and on the product website it is said that any Raspberry PI camera is working.
Now if I try to access the camera, I get the error message, that no camera can be found.

Simple questions:

  • Is it right that I can connect any Raspberry Pi camera or do I need specific ones? If specific, then which ones or what are the specifications required for the camera to be attached?
  • Do I need to install any drivers, which are not part of jet JetPack Image by default? If yes, which ones.

I mean, the problem with the USB camera has been solved by replacing a configuration file; guess that another config file change for the CSI camera should work as well.

Thx for help

RPi camera V2, it works as it is.
RPi HQ camera(imx477 sensor), ISP setting is required.

hello ismet.guelkanat,

this is a topic with cheese application,
please initial another new discussion thread to track your follow-up question.