Sending processed real time stream to another computer though IP network

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU) Jetson Orin nano
**• DeepStream Version 6.3
**• JetPack Version (valid for Jetson only) 5.1.2
**• Issue Type( questions, new requirements, bugs) Sending multiple real time streams through a IP network to another computer

Good day. I am working on a video analytics project using deepstream 6.3 (using python bindings). I want to draw regions on the frames that my deepstream software is analysing and then send them to another computer through a IP network. I have used the python app located at
" as a reference to how to set this up. If I run the software on my ubuntu computer, and open up vlc and play the RTS at the URL "rtsp://localhost:8554/ds-test ", then I can see the processed stream, but if I use my computer that is connected to the same network as my ubuntu computer, and also try to play the real time stream at the URL “rtsp://localhost:8554/ds-test” then the stream is unreachable.

How can I send the processed stream through a IP network to another computer that is connected to the same network as the computer that deepstream is running on? Here is the code that creates the server, factory and the sink:

            sink = Gst.ElementFactory.make("udpsink", f"udpsink{streamID}")
            sink.set_property('host', '')
            sink.set_property('port', 5400)
            sink.set_property('async', False)
            sink.set_property('sync', 1)

            updsink_port_num= 5400
            server =
            server.props.service = "%d" % rtsp_port_num
            server.props.address = f"0.0.0.{streamID}"
            factory =
            factory.set_launch( "( udpsrc name=pay0 port=%d buffer-size=524288 caps=\"application/x-rtp, media=video, clock-rate=90000, encoding-name=(string)%s, payload=96 \" )" % (updsink_port_num, codec))        
            server.get_mount_points().add_factory("/ds-test", factory)

Hi @shaun.johnson

Try replacing localhost in the URI with the Jetson IP address. Make sure your computer can access the IP beforehand by sending a ping.

Thank you that worked! Thanks for the quick help

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.