Serial Communication 1152008N1 Gibberish

Since my HDMI port has no output data, I tried to see if the system is booting via serial port.

I first tried serial port on Raspberry Pi, everything is fine, I can read and write to Raspberry Pi via serial port at 1152008N1 setup.

Then I tried it on Jetson Nano. I can receive data fine, except all gibberish.
Therefore, I tried all other configurations, different baud rate, different hardware, software control combinations, none would work.

I am following the steps here: https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/ everything works for him at 1152008N1 yet all I have is gibberish, can anyone help me understand why that is the case?

Thanks.

There may be a slight bit of gibberish at the very start, but anything beyond that is usually because of a difference in settings between the host and the Nano. For example, different speed settings or different stop bit settings. Make sure it is speed 115200, 8 bits, no parity, 1 stop bit (115200 8N1). Flow control is not used (though I suppose if you have all the wires it wouldn’t hurt).