Serial communication corrupted data

I use L4T 28.2.1 with TX2 and Elroy Board.
I receive the message from external lens via rs422 communication line (baud rate 19200, no parity, one stop bit).
The message comes corrupted in one byte.
The lens send message : 24 29 09 00 11 0D BA 19 1C 01 00 00 01 FE 59
But I receive message: 24 29 09 00 11 0A BA 19 1C 01 00 00 01 FE 59
The difference is only in byte number 6 (0D <-> 0A). I connect communication line to Windows PC for sniffing and receive correct message:24 29 09 00 11 0D BA 19 1C 01 00 00 01 FE 59
I repeat my experiment for 9600 and 57600 baud rates with the same result.
I tried to measure the actual baud rate. For that reason I send 15 bytes from the TX2 board and check the time in the scope. The measured baud rate was about 19500 bps.
Can I adjust baud rate on TX2 board?
What can be reason for receiving corrupted single byte?

I’d start by examining noise in the environment. In particular, shorter length of wiring helps. Given that you probably can’t just make cables a lot shorter, you will also want to use twisted pair. Twisted pair with a ground shield around it is even better. In the past I’ve had luck using ethernet wire for this purpose since it is commonly available.

I have not checked on the actual baud settings so I don’t know if the 19500 or 19200 are valid.