serial: Configured rate out of supported range


I have a similar problem to what is being discussed in this thread (which never lead anywhere):

I am using a TX1 with a fresh install, Jetpack 3.3 (28.2). It is connected to a CTI carrier board called Astro with (among other things) a serial connection.

I have connected a device to this serial port which is constantly transmitting on the RS422 protocol, which I have wired through a RS485 adapter (one-way, since I need only receive the transmission). This is because the CTI carrier board only talks RS232 or RS485. It is mounted at /dev/ttyTHS2. Anyway, this is not my main point:

Everything appears to work (my software that reads the serial port receives exactly the data that I expect it to), but whenever I run my software and actually read data from the port, if I check dmesg for messages I keep getting the same error reported every few seconds:

serial-tegra 70006200.serial: configured rate out of supported range by -0.2 %

The device is transmitting at a baudrate of 19200, no parity, bytesize 8, 1 stopbit.

Does anyone have any idea why this message is showing up, and if there is something I can do to see if I can make it stop? I am slightly worried that something is not entirely correct in the way this thing is wired (by about 0.2% …).

hello andreas.sandberg,

there’s baudrate range validation, please refer to /kernel_src/kernel/kernel-4.4/drivers/tty/serial/serial-tegra.c