I have been trying to get a mpu9250 working with spi on my tx2nx and a a203 v2 board. I have compiled spidev_test and to my understanding if I connect the miso to the mosi pins it should create a loopback and I should see what i send. I get an error about the mode if I try to run a loopback test using spidev_test. at this point I am not sure if it is a hardware issue or me doing something wrong. I have both spi ports showing /dev/spidev0.0, 0.1, 1.0 and 1.1

I have tried the mpu9250 breakout module and the gy-91 which includes both mpu9250 and bmp280. I am able to get them detected through i2c but not spi.

There are SPI0 and SPI1 pins in TX2 NX. Please make sure you enable the correct interface in device tree, and try the test:
How to set gpio for spi? - #27 by DaneLLL

I am using the a203v2 dtb provided by seeedstudio and when using that I get spidev0.0, 0.1,1.0,1.1 however with jetson-io i only get /dev/spidev3.0 and 3.1. I dont seem to be able to make the loopback test work with either dtb.

couldnt post the dtb here so here is a link: /dts-v1/;/memreserve/ 0x0000000080000000 0x0000000000010000;/ { compatib -

I started doing more research and I figured I needed to generate a proper pinmux using the excel sheet. neither using the jetson-io has worked nor the dtb that was provided by seeedstudio. seeedstudios dtb at least gives me the proper spi devices. just not seeing any data etc. Not sure how to get pass this error. Is this due to the version of excel?

Has the SeeedStudio enabled the SPI for both pinmux and device tree?

For TX2, you could refer to the following instruction to use speadsheet for pinmux, but I think it should be done by SeeedStudio according to the custom board design.
Jetson Module Adaptation and Bring-Up - Jetson TX2 Series Adaptation and Bring-Up

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.