Set exposure time limit for LI-USB30-OV10640-490 usb camera

I have usb camera LI-USB30-OV10640-490.

I’m using OpenCV for getting stream from that camera. But I’ve found out that it gives too dark images at the daytime as you can see below.

The day was quite bright, but picture doesn’t have same brightness. I’ve tried to apply gamma correction for it. The problem was solved for daytime, but during nighttime it was working much worse…

So I think it would be nice to adjust exposure time range for this camera in auto mode. To incease minimum value of it so it won’t make so dark pictures.

But I could’t find any information of how to do it both from leopards datasheets, tutorials and webserfing.

I saw that it’s pretty solvable for CSI cameras. But I have USB one.

Could someone give me adviсe, please?

You can query by v4l2-ctl if can set the exposure.

v4l2-ctl --all

Could you give advice for this request.


The LI-USB30-OV10640-490 is UVC compliant and includes ISP. This camera can work on Linux OS directly (no need additional drivers) and output fine tuned YUV data.
Have you tried other video software (like guvcview) to run the camera? Do you see the same issue? We would like to confirm that if the issue is caused by the camera or the PC end software.

Here is the output this command gives:

Driver Info (not using libv4l2):
        Driver name   : uvcvideo
        Card type     : LI-OV490
        Bus info      : usb-3610000.xhci-1
        Driver version: 4.9.253
        Capabilities  : 0x84200001
                Video Capture
                Extended Pix Format
                Device Capabilities
        Device Caps   : 0x04200001
                Video Capture
                Extended Pix Format
Priority: 2
Video input : 0 (Camera 1: ok)
Format Video Capture:
        Width/Height      : 1280/720
        Pixel Format      : 'YUYV'
        Field             : None
        Bytes per Line    : 2560
        Size Image        : 1843200
        Colorspace        : Default
        Transfer Function : Default (maps to Rec. 709)
        YCbCr/HSV Encoding: Default (maps to ITU-R 601)
        Quantization      : Default (maps to Limited Range)
        Flags             : 
Crop Capability Video Capture:
        Bounds      : Left 0, Top 0, Width 1280, Height 720
        Default     : Left 0, Top 0, Width 1280, Height 720
        Pixel Aspect: 1/1
Selection: crop_default, Left 0, Top 0, Width 1280, Height 720
Selection: crop_bounds, Left 0, Top 0, Width 1280, Height 720
Streaming Parameters Video Capture:
        Capabilities     : timeperframe
        Frames per second: 30.000 (30/1)
        Read buffers     : 0
                           gain 0x00980913 (int)    : min=0 max=63 step=1 default=32 value=32
              exposure_absolute 0x009a0902 (int)    : min=1 max=65535 step=1 default=500 value=500
                   pan_absolute 0x009a0908 (int)    : min=-648000 max=648000 step=1 default=0 value=0
                  tilt_absolute 0x009a0909 (int)    : min=-648000 max=648000 step=1 default=0 value=0
                 focus_absolute 0x009a090a (int)    : min=1 max=2040 step=1 default=721 value=0
                  zoom_absolute 0x009a090d (int)    : min=1 max=98 step=1 default=35 value=0

But I want the camera to be in auto-exposure mode (as it is from default) but to increase the minimum value of exposure time in the range. Right now min = 1. How could I adjust this range?

Yes, running guvcview gives same dark image, although it’s pretty bright in there. Here is the screenshot:

And there is no settings to adjust exposure time range

From the query I don’t think there’s a way to set the exposure range.


So, there is nothing to do about that?

Could you do a last testing? Please test the camera on a regular Windows PC? If the issue is still there, there should be something wrong with the camera itself. Then please contact for further investigation.


I’ve checked the camera on Win10 rn. The same problem for me =-( And I can’t change any parameters of the camera. Image is darken. Sorry for russian interface.

This is not a Jetson platform. Please contact for further investigation.

Okay. Thank you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.