Setting "process-mode=1" in SGIE config file gives Segmentation fault (core dumped)

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Below is the detailed error message after exporting GST-DEBUG=3:
sgie_efficientnet_tlt_config_20.txt (3.4 KB)

In cb_newpad

gstname= video/x-raw
features= <Gst.CapsFeatures object at 0x7f271c14e348 (GstCapsFeatures at 0x1925ca0)>
0:00:04.056881913 8326 0x1927b20 FIXME basesink gstbasesink.c:3145:gst_base_sink_default_event: stream-start event without group-id. Consider implementing group-id handling in the upstream elements
0:00:04.056913228 8326 0x1927b70 FIXME basesink gstbasesink.c:3145:gst_base_sink_default_event: stream-start event without group-id. Consider implementing group-id handling in the upstream elements
0:00:04.064777618 8326 0x1927ad0 FIXME basesink gstbasesink.c:3145:gst_base_sink_default_event: stream-start event without group-id. Consider implementing group-id handling in the upstream elements
0:00:04.124252724 8326 0x1927ad0 WARN v4l2bufferpool gstv4l2bufferpool.c:1066:gst_v4l2_buffer_pool_start:encoder:pool:src Uncertain or not enough buffers, enabling copy threshold
0:00:04.211528394 8326 0x7f26b803d0a0 WARN v4l2videodec gstv4l2videodec.c:1673:gst_v4l2_video_dec_decide_allocation: Duration invalid, not setting latency
0:00:04.211552043 8326 0x7f26b803d0a0 WARN v4l2bufferpool gstv4l2bufferpool.c:1066:gst_v4l2_buffer_pool_start:nvv4l2decoder0:pool:src Uncertain or not enough buffers, enabling copy threshold
0:00:04.217329371 8326 0x7f25f43bf0f0 WARN v4l2bufferpool gstv4l2bufferpool.c:1513:gst_v4l2_buffer_pool_dqbuf:nvv4l2decoder0:pool:src Driver should never set v4l2_buffer.field to ANY
0:00:04.245040727 8326 0x7f2690003e80 WARN v4l2bufferpool gstv4l2bufferpool.c:1513:gst_v4l2_buffer_pool_dqbuf:encoder:pool:src Driver should never set v4l2_buffer.field to ANY
Segmentation fault (core dumped)

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hardware Platform (Jetson / GPU) → UBUNTU 18.04 ,
• DeepStream Version → 5.1
• JetPack Version (valid for Jetson only)
• TensorRT Version → 7.2
• NVIDIA GPU Driver Version (valid for GPU only) → 455.32.00
• Issue Type( questions, new requirements, bugs) -
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing) → setting process-mode=1 in SGIE config file
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Please upgrade to DS6.0.1 and check if the issue still happen.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.