setting the i2c speed

I try to change the i2c speed on my jetson tx1 but I do not succeed.
I have tried compiling 64_TX1/ Linux_for_Tegra_64_tx1/sources/kernel_source/arch/arm/boot/dts/tegra124-soc-base.dtsi with

dtc -O dtb -o tegra124-soc-base.dtb tegra124-soc-base.dtsi

and get the error
Error: tegra124-soc-base.dtsi: 17.1-2 syntax error
FATAL ERROR: Unable to parse input tree

I have tested what’s on the and think if it does not work it is because I have a tx1 and not a tk1.

The tegra 12x series is the Tegra K1 (the Jetson TK1 is specifically a tegra124). So this won’t work on the TX1 (TX1 is a tegra210).

I don’t know about the specific change, but I’d suggest exploring the reverse compile of the existing DTB file, possibly editing that, and then recompiling it. Your “/boot/extlinux/extlinux.conf” should name the file with the FDT key/value entry, such as this, which also names where the file is found:

FDT /boot/tegra210-jetson-tx1-p2597-2180-a01-devkit.dtb

Reverse compile, edit, and recompile is similar to this:

dtc -I dtb -O dts -o /tmp/extracted.dts /boot/the_firmware_in_extlinux.dtb
# Explore, edit, so on...then recompile:
dtc -I dts -O dtb -o /tmp/modified.dtb /tmp/extracted.dts

I’d recommend not overwriting the original file and instead using an alternate file name. Then add a second boot entry in extlinux.conf which only differs by the FDT entry. If you use serial console you can then choose to boot to this entry and leave the original in place in case it doesn’t work. It can be a pain if the edit causes a boot failure and you don’t have serial console to fix it (even with serial console it is a pain if the original boot entry is gone).

thanks. That’s what I need to know. now it works.