Setting up a serial console for debug

Can someone point me to a guide open how to set up serial console for debugging of my Xavier agx dev kit

the user guide says that it is possible but doesn’t give any instructions on how to actually do it.

Am I able to use another Xavier dev kit as the host machine?

thanks chris

Hello Chris,

You need a micro-USB cable to do that.

  • Connect your cable’s micro-USB side to your AGX Xavier’s micro-USB pin (J501).
  • Connect your cable’s other USB side to your host PC (it requires any serial console application installed).
  • Open serial console application into the host PC

Into the Host PC
These commands are working for Ubuntu (and should work other debian OS’s (also Jetson devices))
I use GtkTerm as a serial commnication application. If you want to install gtkterm type this:
sudo apt install gtkterm

After USB connected
As you can see that the FTDI connected with “lsusb” command.

Then you can connect your AGX Xavier with:
sudo gtkterm

Finally, set the port and baud rate like that:

Set the Port as “/dev/ttyUSB0” (if you plugged multiple USBs, your device can be different (USB1 etc.))

Yes. To do this, use the same configuration. Your USB cable should plugged in your host AGX Xavier’s any USB-A or USB-C connection.



I think this is the best reply i’ve had to any question on here, genuinely helpful, thanks!

I have it set up, but nothing is happening, just black screen.

My lsusb results was the same as yours Bus 001 Device 008 → that’s ttyUSB0?

do I have to start it some how?

I use dmesg --follow on my Xavier for logging on screen - how to I start it using serial console?

Sorry probably very stupid questions


Did you typed dmesg --follow command at Xavier side right? Not at the host side

on the Xavier I’m debugging

I can’t type anything on gtkterm

I do have some warning and errors on terminal where I “sudo gtkterm”

It’s OK.

Can you type Enter at the GtkTerm

It should look like that
Screenshot from 2021-04-30 18-59-24

(I tried to connect AGX Xavier’s debug pin by itself and it worked)

no its completely black - no type at all

Hi @cdevd,

Is there a possibility to select wrong port ? Do you have another USB device on your machine? The port might be different from “/dev/ttyUSB0” as @mehmetdeniz mentioned above.

my lsusb says it’s “Bus 001 Device 008” - the same as in @mehmetdeniz’s photo so I picked the same port.

I’ve now tried all the other ports but no type appears on gtkterm for any of them.

my only other USB devices on my host machine are keyboard and mouse

Do I need to remove usb devices from my debug machine? It is set up as I would use it normally at the moment


No, keyboard and mouse should not effect this situation.

Maybe you can try another usb cable if you have.
I could not found anything about this error

started again and this time I’m in!

thanks for your help and to @ozguryildiz too

much appreciated!