Setting up deepstream for Quadro P4000

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
Quadro P4000, ubuntu 20.04
• DeepStream Version
6.1 and 6.2
• TensorRT Version
Couldn’t install it successfully
• NVIDIA GPU Driver Version (valid for GPU only)
11.4
• Issue Type( questions, new requirements, bugs)
installation guide is not working

Can you provide the detailed steps and result for each steps? It would help us to find the potential reasons.

I walked through the documentation stesps and this what is happening at the end in today’s trail with installing deepstream 6.4 :

I’ve purged all old installations and drivers

deepstream-6.4 : Depends: libglib2.0-0 (>= 2.72.4) but 2.64.6-1~ubuntu20.04.6 is to be installed
Depends: libgstreamer1.0-0 (>= 1.20.3) but 1.16.3-0ubuntu1.1 is to be installed
Depends: libgstreamer1.0-dev (>= 1.20.3) but 1.16.3-0ubuntu1.1 is to be installed
Depends: libgstreamer-plugins-base1.0-0 (>= 1.20.1) but 1.16.3-0ubuntu1.2 is to be installed
Depends: libgstreamer-plugins-base1.0-dev (>= 1.20.1) but 1.16.3-0ubuntu1.2 is to be installed
Depends: libnvparsers-dev (>= 8.0.0) but it is not going to be installed
Depends: libgbm1 (>= 23.0.4-0ubuntu1~22.04.1) but 21.2.6-0ubuntu0.1~20.04.2 is to be installed
Depends: libglapi-mesa (>= 23.0.4-0ubuntu1~22.04.1) but 21.2.6-0ubuntu0.1~20.04.2 is to be installed
Depends: libgles2-mesa-dev (>= 23.0.4-0ubuntu1~22.04.1) but 21.2.6-0ubuntu0.1~20.04.2 is to be installed
E: Unable to correct problems, you have held broken packages.

Please refer to our Guide dGPU model Platform and OS Compatibility. DS6.4 needs Ubuntu 22.04.

I’ve installed the 22.04 and also did what the installation says but it’s not working and it gives me the error above, the Quadro p5000 driver is not compatible with NVIDIA driver 535.104.12 and I’ve tried to install Quadro p5000 driver from

image

but also didn’t install and when tried to install TensorRT it make this same error

libnvinfer-dev : Depends: libnvinfer-headers-dev (= 8.6.1.6-1+cuda12.0) but 10.0.1.6-1+cuda12.4 is to be installed
libnvinfer-plugin-dev : Depends: libnvinfer-headers-plugin-dev (= 8.6.1.6-1+cuda12.0) but 10.0.1.6-1+cuda12.4 is to be installed
libnvinfer-samples : Depends: libnvinfer-lean-dev (= 8.6.1.6-1+cuda12.0) but 10.0.1.6-1+cuda12.4 is to be installed or
libnvinfer-lean-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
Depends: libnvinfer-dispatch-dev (= 8.6.1.6-1+cuda12.0) but 10.0.1.6-1+cuda12.4 is to be installed or
libnvinfer-dispatch-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
Depends: libnvinfer-vc-plugin-dev (= 8.6.1.6-1+cuda12.0) but 10.0.1.6-1+cuda12.4 is to be installed or
libnvinfer-vc-plugin-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

I did install the driver with ubuntu package manger apt-get but installed the latest I think and I cannot find how to install a specific version now

Could you try to fine the driver from https://www.nvidia.com/Download/Find.aspx?lang=en-us and install all the corresponding software versions. Please refer to our Guide step by step.

I tried to it with multiple versions but it ends up failing to compile the new kernel

can deepstream 6.4 be installed with Quadro P5000

after specifying some versions while installation it finally installed fine

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.